Support

Open search

Ramdom vibrate notifications - galaxy watch

Highlighted
First Poster

"Bluetooth Disconnection Alerts". Go into Settings - Connections - Alerts. Turn this feature off.  Helped some users.

Highlighted
First Poster

Thank you for the response but the key word in there is "some". I've turned off those notifications and my still buzzes non-stop. I changed from Apple products to Samsung and I'm very disappointed in the watch! 

Highlighted
New Member
But then, when you head out for work, and forgot your phone, the watch doesn't remind you.
Mine vibrates regularly, with the phone just inches from the watch.
This is my second Samsung Watch model. It's better than the first one, but still... SO MANY BUGS.
Highlighted
First Poster

I just bought this watch yesterday and I'm just glad it's not me missing something. AGREED to this entire post, and honestly a little disappointed. 

Highlighted
Observer

Exactly the same sentiment as OP. The alerts are not what I want to disable. It's good to know when it disconnects. What's irritating is the lack of CONTEXT of why the vibrate occurs. It shouldn't be an "unlockable wow mystery solved!" that disabling BT connection alerts stops the random vibrating. The vibrates should absolutely always accompany the watch face lighting up and saying "hey, here's what I'm vibrating to tell you!".

 

Having it vibrate without anything happening on the screen is like someone tapping you on the shoulder and disappearing.

Top Liked Authors