Support

Open search

Gear s3 frontier not opening the contacts app properly

New Member

I recently got my s3 frontier and had it all set up except from loging in my samsung account

However the wearables app wouldn't let me log in.

Therefore I tried to reset the device, to see if anything would change.

While reapplicating the settings to the watch I tried to customize the contacts widget by adding my favourite wontacts as I had done previously, however my favourited contacts didn't appear on the top of the list, the three of them had their custom icons missing (which is very confusing since their default icon is the same) and one contact was missing altogether. 

Since then I have reset my device a couple of times but to no avail.

For your information I  am using the google contacts app as my default and the watch is displaying the contacts list from the proprietary contacts app (duplicates and all, with the notable exception of one of my favourite contacts)

Also I am using a huawei mate 10 lite

 

 

FYI the afformentioned login problem still hasn't been resolved, but it is being discussed in another forum

Top Liked Authors