Support

Open search

Gear S3 Shealth killing battery life, always tracking steps

Apprentice

I recently purchased a Gear S3 Frontier, and I love it. However, even after disabling all Shealth settings and after navigating all other settings on the watch and my phone as well as wearing for a day, the thing that uses the most battery life is Shealth. I do not like it. I don't want my steps tracks, or my heartrate monitored. There has to be a way to turn this stuff off. Why would Samsung not allow you to choose an on/off setting for monitoring? I covered the back of the sensor and force stopped the app but it's still on. If this was disabled, you could gain 75% longer battery life without having to use any power saving settings. Personally, I keep the brightness all the way down, notifications to a minumum and everything else off and out of the background. My goal is battery life.

So how can this Shealth app and monitoring be disabled completely?

Like I said, I love the watch, but if this cannot be disabled, I will be returning it until they release a version or a new watch that does not have monitoring always running, and can be disabled by the user.  

6 REPLIES 6
Superuser I
Superuser I

I personally do not have s-health activated on my phone and have my Gear s3 Frontier Watch to track my steps only. 

 

I used the preferences on my watch settings to turn off the Heart Rate Monitor etc. 

 

The only part of s-health I use is the Steps feature and my watch from full.charge easily gives me 3 days between charges alrhoygh i tend to keep it topped up and even tho I do text from it regularly and recieve lots of notifications and emails etc. 

 

I do not have always on display activated with the time out at 30 seconds and brightness set at 5. 

 

If you need to see any of my settings please ask which ones and I'll be happy to screen shot them for you. 

 

 

Current Phone ~

Samsung Note 10+ 5G _256Gb > Model: SM-N976B._ Samsung One Ui / Pie.

Samsung Gear s3 Frontier Watch
Samsung Galaxy Tab A {2016}SM-T580

Apprentice

I also do not have the app on my phone. I do not use the heart rate and have disabled all notifications and other settings in the Shealth app and through the normal settings as well. It still tracks steps, and stairs. There is no way to disable this?

I charged it yesterday when I first got it, and it has been on for about 20 hours now with the battery at 53%. In battery settings, the Shealth is the number one draining app. This is with every option disabled. 

What I have gathered from everything else I read online, is there is no way to disable Shealth or monitoring (steps). I like the samsung watch because I have the Galaxy s8 and everything ties together through my samsung account, so I am not really looking to compromise for another brand of watch. I also do not want to use power saving or "watch only" settings because I enjoy the screen I have with AOD, and it barely uses any battery life with my brightness and settings just like on my phone. I keep the bezel wake and the gesture wake off as well. My brightness is at 1, but in the sun it kicks up as it should. I dont like the gesture mode because it gets triggered very easily, and I already turned the screen on with the bezel option multiple times just doing around the house things today. I also work in an envirnoment where I may not be able to press a button or turn the dial to check the time. Having AOD allows me to view it without the brightness kicking up or the random triggers either of those options present. Same with AOD on the Galaxy S8. I just don't understand why they don't have the same options as far as display goes. All I want is Time, Date, any current notifications and battery life. Even in power saving or "watch only" it manages to have this ugly screen with a step counter. Absolutley terrible. An option like the S8 AOD would be perfect.

While some people may find the app useful, there is still no reason for it to always be on, or not allow the user the option of turning it on or off. How could Samsung overlook this and how has it been nearly 2 years without the issue being addressed? 

Explorer

Hello ! 

 

I'm using the Tizen 3.0.0.2, the latest update on my one year old Gear S3 Frontier.

 

The battery lasts 2 days with AOD off. SHealth just ate 12% of my battery since the last charge. I disabled everything in the app ... the clock is stripped to every little option that could save some battery (even monochromatic display, no sound - just BT on for messages, that are like 10 / day). I'm using it in the office for calendar appointments - having a dedicated calendar watch face is really nice, because I can see the customer's name only by looking casually at my watch ... yeah ... I know ... I have a terrible names memory )

 

 

I will try with AOD on, just for fun. But I think it won't last the day ... so the watch will become useless in this case.

 

In my opinion, it's not even a software fault now - there was a battery drain problem, fixed with 3.0.0.1 - Samsung just saved some $$ by giving us a scarse battery that dies after one year. I don't even have the warranty anymore to replace it for free. This will be the last watch I'm buying from Samsung, no matter how flat or nice will be the S4.

 

Cya and GL !

Apprentice

I completely agree. I have since turned the AOD off, which I dislike but have gotten used to. This was my main scare about buying these watches. They will not last. There is no way they can. I love the features of being able to leave my phone in my pocket but for the compromise of paying so much for a new watch every couple years due to battery issues, is it really worth it? Only a fool would think so.

New Member

I got the new Samsung Watch almost 2 weeks ago and I noticed that in the last 36 hrs since the last charge, SHealth used 32% of the battery. I'm getting about 3 days of use before charging again.  It makes no sense to me to keep disabling options because by the time you disable everything that eats battery you end up just having a regular watch that only tells you time. non-sense!  I'm just about the 2-week mark for its return and I'm that's likely what I'll do. 

Highlighted
First Poster

Go to app permissions and then turn off sensors and location for that app. I did this for the samsung galaxy watch. Not sure if this will work on Gear s3, but you could give it a try.

Top Liked Authors