Support

Open search

Gear S3 GPS Issues fix

Apprentice

It will never finish because they simply cannot fix it. By the way…UPDATE: I upgraded (like most of you probably) to Tizen 4 last week. Now I noticed that when I set up S. Health for the first time after the Update for the running option it asked me to choose between “high precision” or normal one. When I saw that I said to myself…yes!! Finally solved. So I selected “high precision”, I don’t care about battery or anything: I just need it to be precise. And you know what happens now? It measures 1 km after actual 850m, 2 Km after actual ~1.7 Km…and so on. So made a few tests against my wife’s Apple Watch and she got 7 Km track (confirmed by MapMyRun) and I got (running together) almost 10 Km. I honestly give up. This watch is of no use for running or walking.

First Poster

Thanks Buddy,
At present it is with support for another round of surgery. I will try after I have received back.

 

Apprentice
Thanks mate. Will go out for a run today, will keep you all posted.
Observer

was the distance measured in metrics, or US(miles?)? You need to set it up correctly. There seems to be a consistency in the ratio between the measurement and the actual run, and looks more like a conversion ratio between mile vs km.

 

I have Garmin Fenix 3, tried Vivoactive HR, Vivoactive etc and all matches with SG3 Frontier. 

 

Not saying, there is no lemon, though. Either yours could be lemon on GPS. 

Apprentice

Thanks for the hint but of course it is in metric system. Otherwise, it wouldn't work in one type of sport and not in another.

Thank you,

First Poster

Did you ever manage to get this issue resolved. I have the same issue. My watch constantly says records further than actual. Ran 5.7mile yesterday, watch recorded 8.8mile. Took into Samsung shop today but its fair to say the lad I spoke to, didn't have a clue.

Apprentice

Hi,

No, I haven't. Actually, SAMSUNG has never cared about contacting me and finding out more. Always the same answer (reset your watch) and that's all. But I don't want to repeat everything again, just feel free to read my whole story. The watch does simply do something wrong when processing actual (current) pace and also the overall distance is wrong. But bear in mind: this "overmeasuring" happened after the last SW update. Before it was the other way around: always short. Amazing.

Regards,

Apprentice

I am having the same issue..  don't know if it due to one of the apps  update?

New Member
yesterday i ran 5km, 1st km was measured correctly, then it started measuring 1km per every 0.5km. very weird and disappointing.
Apprentice

I known! Did gps go bad? Last normal time i had a normal timing was on Feb 26 .. Has there been an update that has screwed up the tracking ??? 

Top Liked Authors