Open search

Gear S3 Frontier battery drain on Tizen


I did the factory reset and removed the barometer - no luck. I still get a whopping 6 hours of battery life

First Poster

I like my idea better. I'm inches away from starting a class action lawsuit. The amount of people that this has happened to is absolutely ridiculous


You know what really p*ss me off...


You check the similar post of this issue and they appear to be "solved"... You look for what they did or something and its just one dude saying "go to the store to get a diagnostic for your device"... Really dude?... That's his answer for everything...

The samsung store closer to me is about 4 hours of distance... So im not going to drive 8 hours just to get my device factory restored and hoping for the best.


Samsung Crew... We need a real answer for this... An update for the firmware, for the app or whatever is causing this... Don't send your bots saying "go to the store".


Gear S3 Frontier battery is draining fast. It was fully charged this morning and is completely dead by lunch time. Looks like I'm not the only one with this problem. Lets get this fixed Samsung!!!!!! 

First Poster

Hi, I've done all these steps and it's not helped! Samsung please review this issue and give the firmware update to us!


@Alexpc73 wrote:

@UrsusKnut wrote:



Exactly this happened to me today, when i went to sleep it had 90% of battery... Suddenly in the morning when i was getting ready to work *beep beep beep* low battery chime... It have reached 15% just in one night...

I checked out the battery consumption, 13% notifications - 13% samsung health and everything else was bellow 2%

I just googled up this issue thinking it was just a mere coincidence but now I see its not...


Just to let you know guys, i have less than 3 months with this new S3 Frontier and this is a warranty change for battery issues.


Im going to reset the watch and disable all the Shealth features, GPS stuff, barometer and that stuff... Wish me luck

I only disabled the automatic workout detection and currently is working fine

can you describe how you turned that off please ?

First Poster

I like your idea, I'm in!!!!


@catsuk wrote:


can you describe how you turned that off please ?

Check the settings the location stuff or something like that (i dont remember) there you can select between none, only wify and wifi & gps.


For the barimeter and altimeter its just uninstall the app... To be honest guys, thats a really cool feature but almost nobody uses it... I have the alert for the air pressure but it never beeps or nuzzles or whatever it have to do...

Oh yeah, try to use the default faces... they are not that useful or pretty like the others on the store but that could help too... Im doing my tests... Soon as i get some news I will post them.


@MersauX wrote:

I've been having the same issue for a few days now. I tried different things, nothing helped so far. The detect workout is also grayed out for me. However, I disconnected the watch and it became available. Then I turned it off and reconnected the watch. Now it's grayed out again, but it shows as off. We'll see if this helps.

did it help?


@Alexpc73 wrote:

@BobLoblaw wrote:

How did you disable automatic workout detection? It's greyed out in my Samsung Health app settings.

@Hi @BobLowLaw... you're right, it's usually greyed... so, for disable, first of all you  must disable your bluetooh connection in your smartphone... Then open the Samsung health app, disable it from settings, advanced, and then go back to your bluetooh, and enable it

this needs to be sticky so people can see it. Multiple people are reporting this as the fix.

Top Liked Authors