Open search

Gear Fit 2 Pro - Standalone GPS not working


Hi all,


Recently the standalone GPS on my Gear Fit 2 Pro has stopped functioning completely. I've tried resetting the watch numerous times to no avail. I took it to the Samsung repair centre and they replaced the motherboard on the watch and to my surprise the GPS still does not function after having it returned. 


Due to the motherboard being replaced it says to me this is a software related issue. The guys in the repair centre showed me a diagnostic test they ran on the watch and showed me everything had passed. They also claimed due to servicing the watch there was nothing else they could do on a return to the store and suggested that I contact Samsung directly.


Has anyone had a similar experience with their Gear Fit 2 Pro? 

ChrisM Moderator

Hi @L1ng.


Did you take your watch to an official Samsung approved Service Centre?


Post removed

Hi, Yes I took it to the official Samsung repair centre in Plymouth
First Poster

Did you get any further with this? A month ago my gear fit pro started lagging when moving between screens and stopping when using the running app, so I did a reset and now the gps takes around 5 mins (if at all) to locate anything and then drops in and out.

First Poster



 I have the same issue. The built-in GPS does not find signal unless I connect it to my phone via BT and at the same time Location on my phone has to be enabled. I find it really annoying because what is the point of the built-in GPS then? Anyway I sent it to my local Samsung Repair Center and they replaced the motherboard. After I got it back I have the same issue. The built-in GPS is not working. I'm sad. My 220 EUR went to the trash. I tried factory reset too with no success.

First Poster

I have the same issue.  It was functioning well earlier. I sit the gearfit to find its GPS for while, but it never find the location. This really needs a solution Samsung. 

First Poster



 I have the same issue. The built-in GPS does not find signal, only if I connect it to my phone.
All records recorded (without phone connection) are without map-GPS info.

First Poster
I have the same issue. The built-in GPS does not find signal, only if I connect it to my phone.
already twice handed over to the service, twice changed the clock board. After two repairs, the GPS is not working !! Now the clock is the third time in the service. Sorry, but, I think that Samsung f...ed up in this issue.

First Poster

I thing that is a software problem with their samsung sport aplications and you are right - samsung f...ed up in this issue. It is not problem with your watch.
If i try "Strava" app for gear fit 2 (downloaded to watch) disconnect my phone, standalone GPS works well. Strava app activates GPS in a few seconds and after connecting my phone back, the Strava app upload everything to phone even the GPS data. Try it too, you will see it works.
Only Samsung original aplications has this issue.

Top Liked Authors