Open search

Galaxy watch registration

First Poster

Trying to register my galaxy watch.  I entered the modle number, its not recognised.  I entered the serial number, that's not recognised and it's asking for the IMEI or MEID.  But it's the blue tooth version of the watch and as I understand it wouldn't have IMEI or MEID.  Does anyone have any ideas please 

Superuser I
Superuser I

Try clearing any relevant caches etc and close the page down and then re try.


That worked for me when I was registering my Gear s3 Frontier Watch. 



Current Phone ~

Samsung Note 9 Model: SM-N960 Dual Hybrid 512Gb_ Samsung One Ui / Pie.

Samsung Gear s3 Frontier Watch
Samsung Galaxy Tab A {2016}SM-T580

First Poster

Check the Serial key. got the same issue when I first tried to register my Galaxy Watch via Samsung Members app.

For Example with me it was  - 0 or O

IMEI not used


Not the device is registered on my account.


New Member
I'm also facing the same issue. There is no way I'm able to register my watch. I tried everything from clearing cache to double checking the serial number, but still no luck. Please need help for the same.
First Poster
I clicked on the live chat link in this app and they did it for me. I hope this is helpful
Top Liked Authors