Support

Open search

Galaxy buds case not showing light indicator

Highlighted
First Poster

Im having this problem with my galaxy buds where when I open/close the case the light indicators don't come up letting me know the battery of the buds or the case. I know that I can find the battery of the buds in the galaxy wearables app but I cant find the battery of the case which makes this problem really annoying. I use a wireless charger and the lights come on while they are charging but don't when they aren't charging. I have just tried using a cable to see if this fixes anything but no, all that happens is the lights work when I open and close the case about 2 times and then it just stops and doesn't happen again. Is anyone else having this problem or just me, or are mine faulty and should be taken back.

Thanks for reading!

2 REPLIES 2
Highlighted
CarloL Moderator
Moderator

Hey @LoganLawton! Are you still having issues with this? Have you tried using the original cable that came with the Galaxy Buds to charge the case? 

First Poster
I took them to Currys PC World and the guy said the case was dead, and he told me to charge the case fully and see what happens, we did that and the reason that i didnt do that before is because a couple weeks ago i charged it fully with my dads cable and it worked for like an hour for 2 and then started to flicker again, anyway now when i open the case both lights show up red and then change to the colour that they should actually be at and sometimes when i open the case they flicker before that the colours show up which is annoying
Top Liked Authors