Open search

Galaxy Watch stuck in Reboot loop

I just received my Galaxy swatch about a week ago and last night after I got hole from work I turned it off and placed it on the charger. This morning I tried turning it on and it would. It kept saying it was rebooting and after holding down the power button then rapidly pressing it after the rebooting screen appeared I held down on the continue option and the reboot option and both times nothing happens. I haven’t been able to

find anywhere a step by step guide on a reboot loop specifically for the Galaxy watch. 

MasukaH Moderator

Hi @MarcusShepard24


Are you still experiencing this issue? Are you able to access the Menu at all or does it continue to reboot? If your watch does not respond to a restart, have a go at the following steps. Please note, this is a Hard Reset which will erase the existing data you have on your watch. If possible, you can try back up the data on the internal memory.


> Turn the Galaxy Watch off.

> Press and hold the Power key until 'Rebooting' displays at the bottom of the screen.

> Press the Power key three times quickly until the 'Select Reboot Mode' screen displays.

> Press the Power key several times to highlight ' Recovery'.

> Press and hold the Home key for three seconds to select, until the Galaxy Watch begins rebooting.


Let us know if this helps!





New Member
I have the same problem. Followed these steps and although "galaxy watch rebooting" has appeared a couple of times, it just goes blank again and won't progress any further. What next?
New Member

This worked for me thank you

New Member

This happened to me a few days ago and I didnt realize what was happening at the time. It is now completely dead, will not turn on. Is there anything I can do to fix it at this point?

Top Liked Authors