Support

Open search

Galaxy Watch not recording steps

First Poster

 

 

Ok yet another issue with my new samsung watch, the infamous 'not recording steps' problem.  Can't really understand why a company like Sumsung is releasing such shoody hardware and software. Anyway I noticed a couple of things, one that the Health app on the watch itself was crashing and not loading, along with a few other apps. I tried the blank watchface etc and still nothing.

 

The only thing that worked finally for me was a complete reset and then straight to a plain watch face. waitied a bit, moved about and finally the health app on the watch was registering steps. Switched to a more complex watch face and still recording steps so seems fixed for now.

 

However this is unnaceptable and I suspect its something to do with LTE. The software is getting confused about where its meant to be getting its data from (I'm a software engineer) so just fails.

 

The steps are still not accurate however, deep sleep not recording etc etc etc #sigh

Top Liked Authors