Support

Open search

Galaxy Watch always on display not working

Highlighted
Apprentice

Some watch faces will kill the (I am alive) app. You have to try different ones. The one I have (BORA_Black_Factory) is a great watch face that does not kill the (I am alive) app. That is the only watch face I use. It has everything you want in a face including, music,phone,messages,heart rate, battery,footsteps.

Highlighted
First Poster

I was going insane trying to figure out why my watch wouldn't stay on, went through all the different techniques everyone talked about to fix it and nothing worked. Oddly, the watch worked perfectly on my right wrist but wouldn't work when I wore it on the left. Then I noticed that the tattoo on my left wrist was interfering with the sensor. I could move the watch anywhere on my left arm that didnt have ink and it worked perfectly. Placed over the tattoo it wouldnt sense my heartbeat and the screen would turn off. 

Highlighted
First Poster

This is very intersting and perphaps something Samsung should research and test on.

 

Just a thought, most colors of standard tattoo ink are also derived from heavy metals, could that be a cause of interference?

Highlighted
First Poster

Found out it doesn't  work if you have ink. Works fine over clear skin

Highlighted
Explorer

@GodSonKnight wrote:

Found out it doesn't  work if you have ink. Works fine over clear skin


 

That's strange, I have full sleeves on both arms, mine works ok 90% of the time. Wore my wife's active watch and it worked 100% of the time!

Still think this is a sensor problem tbh

Highlighted
First Poster

I have a dark tribal tattoo on my left arm screen always goes to sleep on my left arm  but the watch works fine on my right arm 100% of the time where I have no tattoos

Highlighted
First Poster

Might be the density of the ink or the color, or type of ink etc.  My tattoo is black and pretty dark.  The watch definitely flips out over the tattoo and works normally on any other patch of skin.

Highlighted
First Poster

hi everyone ... Galaxy watch is one of the best smartwatches in the market ... i think i found the solution for AOD not working ... go to Health app  ( in your watch ) .. then scroll down till you reach ( Sleep ) option .. scroll again till you reach ( gear icon) which is for setting ,where you can see ( Record REM sleep ) .. tap on it and switch to off .... this option tracks your sleeping time to reduce battery consuming so that when you go to sleep , the system switches AOD to off automaticly ... i hope this solves the problem for you .

Highlighted
First Poster

I have the exact same problem. So here's what I did.

I was pretty sure that problem is in sensor. So I simply took my watch upside down, you know, like some old people do. Heartbeat is more feelable on the bottom of the wrist, not on top and -- voila--it worked! AOD works perfect, so my guess is watch monitor your heartbeat and if they can't - they turn off. I have a thin wrist and sensor simply can't recognise my heartbeat. So it got nothing with watchface or anything - problem is with sensor. So it's a bug, I suppose or cheap sensor. 

Highlighted
New Member

This reset did not work for me. What DID work was changing Samsung Health Settings - HR and Stress Measurement to Measure Continuously (instead of every 10 minutes).

Top Liked Authors