Support

Open search

Galaxy Watch Designer: unable to connect Active 2 watch

Highlighted
SOLVED
Superuser II
Superuser II

Hi, does here somebody use Galaxy Watch Designer?

I have issue with conencting to the watch from Designer. I'm on the same network as the PC (Windows). The watch is connected to Wi-Fi and responses to ping.

2019-12-23 09_30_36-Administrator_ Windows PowerShell.png

When I try to connect over BT, I uploaded into the phone sdboverbt_160523.apk which I found in the folder C:\Program Files\Galaxy Watch Designer\tizen\tools. When I run it manually I can select BT device and I see the phone in Designer but when I click on it the watch disconnects from the phone:

 

Screenshot_20191223-092846_sdboverbt.png2019-12-23 09_28_58-Galaxy Watch Designer.pngScreenshot_20191223-092855_sdboverbt.png

 

When I try to connect throught Wi-Fi, then I cannot add the watch. When I try to Scan devices I got message that nothing was found, when I set the IP manually I got message that the device is not compatible.

 

2019-12-23 09_31_32-Galaxy Watch Designer.png2019-12-23 09_31_41-Galaxy Watch Designer.png

USB debugging is enabled on all devices.

I'm desperated, what should be wrong?

Watch: Active 2, One UI 1.5, Tizen 4.0.0.7, SOftware R820XXU1BSJ6

Designed version:

2019-12-23 09_17_03-Galaxy Watch Designer.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Same problem with the watch active 1, this is going to sound silly but, turning off debugging, closing the deisgner app, restarting the watch, re enabling debbugging, rebooting the watch, re-opening the designer tool worked for me.

 

I was having the exact same, S7 would connect, ADB over bluetooth would connect, but then when selecting it would disconnect

 

(Christ my first  post and im sugesting "turn it off and on again" )

View solution in original post

2 REPLIES 2
New Member

Same problem with the watch active 1, this is going to sound silly but, turning off debugging, closing the deisgner app, restarting the watch, re enabling debbugging, rebooting the watch, re-opening the designer tool worked for me.

 

I was having the exact same, S7 would connect, ADB over bluetooth would connect, but then when selecting it would disconnect

 

(Christ my first  post and im sugesting "turn it off and on again" )

View solution in original post

Superuser II
Superuser II

God bless you, it have worked!

Top Liked Authors