Support

Open search

Adoptable Storage Tab a6 16GB LTE

Highlighted
New Member

I've had samsung devices for the last few years (since my trust S2)

 

I know that samsung have removed the framework for adoptable storage but hopefully the whole post below will be read before someone replies to tell me just that.

 

I have a Tab a6 16GB.  It's all just been set up and i've only got 4GB of space left to install apps and do my thing.  I like to install things on my tablet such as games that tend to have a large additional download. 

 

So one game in, and i like to have several installed as i travel a lot (keeps me entertained), and i've ran out of space.  So I try to move the app data to the storage card, but it only moves around 200mb out of the 1gb download.  Slightly annoying.  So I think ok, i'll add an SD card and format it as internal storage, but that's disabled on samsungs..........

 

So i try to find out why.  Aparently samsung believe that SD cards are only used to transfer files and photos?  Personally, i use a USB cable for that, and there's also this thing called the internet that's really handy for moving things around

 

Jokes aside, the expansion slot on android 7+ devices is just that, for expanding memory.  Google added the adoptable storage framework to allow manufacturers to keep producing low RAM variants but to allow the end users the ability to upgrade both internal and external storage.

 

So there may be a problem with conterfeit SD cards messing up devices that use adoptable storage, but surely samsung could add the feature back in and allow it on a user's liability notice, that any damage caused by using adoptable storage would void warranty on repairs related to a corrupt filesystem, or make devices with 32gb internal as standard, as leaving a couple of gig to install apps gives me a very expensive kindle, not what I would expect at all from Samsung.

 

I did also think that perhaps it would interfere with Knox, though as Samsung appears to be removing myknox, and I don't use it anyway, is there any chance of reinstating the framework so that advanced users can enable it via adb again? or adding it in as a UI selectable option with a disclaimer on warranty so that we can make use of it?

 

Regards,


Vel.

Top Liked Authors