Support

Open search

UE55k6300AK - Blank screen - Controls appear but dont work

New Member

Okay so today i was putting on Netflix for the kids to watch and it froze, Return - Exit - Power buttons on the remote did nothing so i held down the power button to make it turn off, and it wont come back on. The screen is blank (not dead black more like browny black so you can tell theres power to it) and if i press the single "control" button on the bottom of the TV the Digital "Console" appears and you can move between the 6 choices Power - Channel - Volume - Source, However clicking any of these does nothing at all. The remote makes the red light flash but also has no effect.

Things i've tried:

I've tried some button combo on the remote that i found on a forum somewhere to factory reset the TV - Nothing

I've unplugged the TV from the wall and held down the power button to remove any left over power (for up to 60 seconds) and the tv has been unplugged for varyin periods up to a hour or two - Nothing

I've tried using different plug sockets - Nothing

Anything ideas would be appreciated.

1 REPLY 1
CarlH Moderator
Moderator

Hi @ButteredToast. It seems you've gone through most the steps I'd normally suggest and as such, it might be best if an engineer inspected your TV. This link will direct you to the closest Service Centre in your area. 

Top Liked Authors