Open search

Samsung Smart TV stopped connecting to internet (wifi and Ethernet)

New Member

I see there are now 11 pages on this issue - come on Samsung you can do better than this.

My TV stopped recognising wifi after it updated...  I've tried many of the suggestions with no joy.

I already wasted enough time trying to fix this issue... this is unnecessary and shouldn't happen.

I would like to hear from Samsung about how to fix this with the minimum of fuss


I have contacted them 3 time pointing them to this post. Each time all they do is offer me to a call back from support. After messing around on the phone we manage to get an intenet connection that works for them long enough to connect to my TV using my mobile phone. They then proceed to blame my internet connection which is happily running all of the other 40 devices on WiFi in the house. My new 4k Fire TV stick is working extremely well now but the next TV I buy definitely won't be a Samsung after this fiasco. It would help if they would just admit the software has a bug.


Same story my side, also blaming my service provider and doing the mobile connection story... I am now using my PS4 to connect without any hassles, however, it is the fact that one pays so much money for what should be a superior product only to have issues such as this? 


It is clear that Samsung does not care... Only way for them to care is for us consumers to take our business elsewhere...

First Poster


I was looking for the WiFi module for my tv but now being told that it’s the main board,


please s have a look and advise if I should change the board or if you think it’s software related issue. My tv won’t connect to the internet even with an Ethernet cable. 

First Poster


im sorry I cannot confirm the motherboard, but I do have an idea that might be easier.
Why not buy a smart TV stick like from Amazon or Roku?
It will be less money and you can try it quickly and return it if you had to.

My fear with a motherboard is if there is a version that works and older ones that do not.
This could end up being a frustrating exercise.

In my case, I have a android TV box connected and its like a mini PC, as it has access to all android apps, browsers and a BT keyboard.

Yes its one more device, but it has more Smarts than any smart TV.

The truth is that even if my TV wifi worked, I still would use my Android box as its more versatile. 


Most likely you guys are experiencing the same issue as me. Refer to this topic and confirm the behavior: LINK

Please confirm if the issue happens only on WiFi or with cable / ethernet also.

My router uses Cloudflare DNS ( and all other clients work without any issues, except the Q6FN.

Also the router uses the same SSID for 2.4 and 5 GHz antennas, disabling one or the other does not help...

New Member

I have the q6fn and it’s a week old and right out of box will not connect to wired, only after unplugging Ethernet ( cat6 ) from tv the tv beeps and then I plug it back in then it connects every time. It might work for a day then the next day again with problem. 


On WiFi the TV stays connected approx. 5 minutes after you turn it off (after it goes to sleep).

I have verified this through my routers web interface, and this can be reproduced consistently.


Then if you turn the TV back on (after those 5 minutes), it would try to reconnect to the WiFi network. In my case it would reconnect to the router sucessfully on the first try, BUT none of the Smart Hub apps have access to the network on the first try... I would have to re-enter the apps for them to get connected.


Also on the second try of opening the app, the app would start from scratch (with a $APP_NAME loading spinner), while on the first try of opening the app it would not.


This lead me to believe that Samsung caches the application's state to try and make it's loading times appear faster. This would in turn result in an network error.


TL;DR there is a bug in the SmartHub service where it does not register that it has been reconnected to the network

First Poster


i have managed to fix the issue on my tv. My Samsung smart tv UE48H6400AK stopped connecting to internet wirelessly or with Ethernet cable. Remote control response was slow too. I bought a main board for my tv from EBay, I bought the main board rather then WiFi module as I struggled with wired network connection. I was able to change the board easily and now I have a fully functional tv. 


£55 was my cost. 


May be the last update killed the old board? I have since unticked auto update on the tv.

New Member

I'm in the exact same place with my tv. I used to reset the network, now the only thing that works is disconnecting power to the tv for a few min. Have you acquired any new information?

Top Liked Authors