Support

Open search

Samsung Smart TV stopped connecting to internet (wifi and Ethernet)

Apprentice

Samsung is pathetic! Everytime I deal with them I tell them they have to help the people on this forum. Its ridiculous. The problem is samsung, luckily I was still under warranty. The technician told me that the TV doesn't support fibre. Only way to fix is with technician (if other suggested work around dont work). If you try another work around you may need to Repeat again.

Apprentice

Hello Samsung?

 

The silence is defeaening...

 

Love how Samsung is getting lambasted on their own site and do not even bother to offer guidance or acknowledge the fact that their overpriced product is clearly flawled?

New Member

I have been struggling also and this forum has helped me a lot. I have tried fixed ip numbers etc, but.....

Since I have removed the WiFi 2.4ghz all is working fine: seems like working with 1 ssid network name on 2.4ghz AND on 5ghz gives a problem of disconnect.

Hope this helps.

 

Apprentice

Hi all, Thanks for the updates on how you are getting on. Mine has been working but very unreliable. I decided to take the plunge and buy a 4k fire stick yesterday as it's just too fiddly and time consuming. Samsung have lost a customer as next time I will go elsewhere for for a TV. It's so annoying as TV has been great otherwise. 

First Poster

HI everyone.

 

This could end being a long reply, but ill try and keep it simple.

 

Im here as I also have all the symptoms described with Wifi while a lan cable direct to the TV works fine.

However my home network is a bit strange as I have 2 routers in place and added another  just for testing the TV.

summary of results when trying to connect my UE406400.

I should say that all routers connect to the internet and have many devices connect to them and working 

 

Router 1

BT home hub 5 :

sometimes not see the Wifi network

sometimes connect to the Wifi but not see the internet through the router.

 

Router 2

Asus AC66C

Can NOT connect to the Wifi at all

 

Router3

TPlink VR2600 

Connects everytime and stable.

 

for anyone that is still interested...

The BT home hub is connected to the telephone line so is the main connection to the Internet

 

The Asus Wan port is connected via a LAN cable to the BT hub . The Asus is setup as a VPN router so that I can connect to a VPN with some devices while other devices can connect to the BT home hub at the same time. 

 

The TPlink (set up for this test) is connected via a lan connection from the Asus to the TPlink wan port.

 

Phone line  >>>>>>  Home Hub5  >>>>>>  Asus  >>>>>>   TP link

 

so the 3 routers are connected in series to the same single internet connection to my house.

This tells me that it is not the internet or how the internet passes through the routers, but rather something in the Wifi compatability.

 

for those that know the TPlink, this router can replace the Home Hub and this was my setup till 2 weeks ago and it also works with the TV.

The reason I dont leave it this was way is because the TPlink has problems with the RING doorbell so went back to the BT home hub.

 

so looking at all the replies, the new motherboard may be a new Wifi module that works and some of you have used extenders which is maybe why some work and some dont as its down the the Wifi electronics.

Also maybe some of you have seen things change as maybe there was an update to your router or to the TV that killed the compatability (there maybe something is the advanced settings for Wifi such as the encryption, but I could not see what)

 

I have been thinking about buying a newer Home Hub 6 of ebay and if I do then I will test it, but right now, I can not justify another router.

 

If I was to offer any advice to someone suffering and cant get a new motherboard, then id look for something like a TP link access point to connect your router, this can give you Wifi in another part of your house while also being able to connect to your TV.

 

Im not sure if there are any Samsung Techs that watch these forums, but if they do and want me to test anything then im available. 

 

Hope this helps in some way to those that can try another Wifi device. 

In my case, im not sure ill leave the TPlink connected as its overkill for this use, but maybe ill use a Ethernet over mains adaptor (such as powerline) and then just connect a lan cable, as I have one spare.

 

Regards 

TK

 

Just Browsing

Greetings,

I just joined this group and seen everyone else having this issue. Please note my setup.

Q9 75 Inc

NVIDIA Shield

Aerohive NG AP's

Sonicwall FW

Cisco & Dell Switches

                                                               

Spectrum---->SW FIREWALL-----Cisco 3560E---DellS3124P--AP250 

                                                                       |

                                                                       | _ AP250

Back story:

I have had this tv since Aug of 2018, when the screen began to dimm all black in Dec. I got an engineering special from Samsung in Jan 23. About four days later I got this issue as well. The first troublehsooting I did, was ensure my IPAD's can get to the internet which they did. I then started looking at my Aerohive NG (WIFI Cloud) and seen that the TV was disconnecting itself. I thought that was strange, and after calling Aerohive, they stated that the tv would be the issue since every other Device, 2xIpads and phones, not to mention my NVIDIA Shield PRO TV.

 

Now the fun starts:

I call samsung, troubleshot with Louis for over an Hour, he made changes stating that changing the DNS would help solve this problem, however, I am a network engineer and knew that wouldn't be the case and it was quite commical when he disconnected himself from the Remote TV Session. Either way he made the change, after 1min 23 seconds (logs from my WIFI) the TV disconnected. He then went to hidden menu and stated that there is a feature that has the TV terminate the connection, so he turned it off, and I thought it would be fix. As we were stating our pleaseantries, well it happened again. 

 

Next the call drops and I can get back to him, after calling multiple Samsung to re-explain everything, they do more troubleshooting, reset the TV to factory and other stuff and finally I have a technician coming.

 

The issue now is that my tv is mounted about 2 ft on the wall where there is a mantle and well they wouldn't touch it. So the Service Quick rep told me to call samsung. I then pleaded with samsung to please use my retailer Fry's which I spent 600 bucks for 2 year support contract, and had them install it, well they said no and can only be Service Quick and Tekniton in the San Diego Area. 

Finally service quick called me back and stated that they would send two technicians to help unmount the tv, and for clarity I also stated I would help them, so I called samsung and let them know of the good news and they stated great, we will dispatch two technicians. Great! I was happy.

 

So finally the day of service Tekniton Eugene shows up, I was puzzled, I thought service quick was coming but I am happy since we can get to the root cause.

 

He was suprised on my setup on the tv being mounted on a wall and he wouldn't do it and took pictures.. oh yeah not two techs just one, i pleaded with him that if he can help me unmount the tv we can do it, but he couldn't do it, and I get it, a liability issue so I let it go. So then he does troubleshooting and  states that its a power issue with the one box, yet again another appt. 

 

Finally yesterday shows up Daniel from Tekniton, and boy did he have an attitude. Tells my wife "if you want anything fixed that tv needs to be down" finally i get out of my meeting and start explaining. He replaces the onebox and we cant connect to the wifi, he puts it on his cell phone mobile hot spot and looks at me like I am an *****... "see it works"

I was like wait, i try to explain to him about my logs, and debugs, and states I don't know any of that, I say I do. Finally the TV connects to my Wifi and I am happy because let's see if we can see it happen. I tell him to take a picture of it, and we start streaming.. And finally it happens, it stops because I see it in my logs. And i tell him, he then states "it still playing" i then go to networking status and yes disconnecting but Netflix is just cached i tell him. He cant explain it, connects to his phone again and states "it works with my phone".... Frustrating! This kept happening for a while, and through the whole troubleshooting session I had put my daugthers IPAD streaming a 3 hour movie from Netflix and it never dropped. He couldn't explain it.

 

The technician's response and Samsung agrees that Its "my Network"

Since the tv was mounted on the wall they couldn't replace the WIFI Module. SO i have to call back, however I think I am done with Samsung. After having my 55 UN tv for 9 years and decided to go with the slick Q9 expecting High End tv, and now have buyers Remorse on a tv over 5K. 

The workaround that I did is put the Hulu App on my NVIDIA shield TV and just stream it from there. The TV is not reliable, and Samhung really hung themselves with this experience as it seems I'll be going with an Android TV when this TV dies. My manager has stated samhung uses subpar equipment and he recommended the LG. I wish I would have spoken to him before I purchased this TV.

 

Goodbye Samhung, you lost a customer for sure on this one.

Apprentice

They did exactly the same to me. They said it connects on my mobile phone and therefore it's my internet. I ended up buying a 4k fire TV stick and it works perfectly. I resent this to the point that I will never have another TV from Samsung. I contacted them and directed them to this thread and they asked me to log it with their developers though the registration page but my TV is out of manufacturers warranty so it would let me. I guess we must all have poor networks and internet connections with our differing  equipment and service providers! Samsung - the internet redefined! Now where did I leave that USB magic wand? 

Apprentice

I'm having the same problem on my 9 series TV.my tv keeps disconnecting so I have to do a power cycle so I can re enter password to connect again.did you find a solution thanks lee

New Member

You can just create a static dhcp lease on the router and this will keep your TV connected . This resolved my issue .

First Poster

Hi Vladi86

please advise on how to create a static DHCP on the router, I have virgin media super hub 3.

 

thank you

Manish

Top Liked Authors