Support

Open search

Samsung Smart TV stopped connecting to internet (wifi and Ethernet)

Highlighted
First Poster

Just order a Roku or Firestick.  Plug it in to your TV and your problem will be solved.  Neither drop their connection nor do they have to be reset, powered off, reconfigured........ We have two new Samsung Smart TVs and both now have a  streaming device (that works!). Neither has lost its signal since.

Highlighted
First Poster

I am using Roku. I can watch Netflix, but Britbox is what keeps disconnecting from my wifi. I get a message that I am not connected to the internet.

Highlighted
First Poster
Ok thanks will do
Highlighted
First Poster

I had this issue a too, the solution was the tv country code was set to USA.  

 

See there was a software update and it changed all the settings.

 

 

Highlighted
First Poster

@Jamie0423 wrote:

I had this issue a too, the solution was the tv country code was set to USA.  

 

See there was a software update and it changed all the settings.

 

 


🤔 interesting 

Highlighted
New Member

This worked. Used remote. Held until Logo appeared and restarted by itself. 

Highlighted
First Poster
yes this sucks and 3 hrs with Samsung "support" was no help at all
Highlighted
First Poster
Samsung customer service said and I quote. "We know the issue it's a easy fix. But I can not help you your tv is out of warranty.

I have 4 Samsung TVs guess who is never buying a Samsung again.


I did a Google search to find a solution
Highlighted
Apprentice

They are awful , I wont be buying another Samsung.

Highlighted
New Member

I was able to get the WIFI to work and not drop. To do this I had to:

 

1. Log into my home router and allocate a static IP address to the WIFI. 

2. Go to the firewall section of the router and add an exception to the firewall to allow that static IP to pass through the firewall at all time. 

3. Enable MAC Filtering for the Samsung TV and add the TV to the MAC Filtering list.

4. Extend the DCHP lease to 99 days

 

This allowed the WIFI to work. I also have a ethernet cable hard wired to the back of the TV. I took similar steps here, but the smart hub diagnostics continued to say that the ISP was blocking the TV even after I added the hard wire IP to the firewall passthrough. I really want the TV on the ethernet and will continue to work but these steps have worked successfully so far. I have not had the TV very long and debated taking the TV back for a refund due to this issue. 

 

Just as FYI, I have used a Roku and Firestick without any issues. 

Top Liked Authors