Open search

Samsung Smart TV stopped connecting to internet (wifi and Ethernet)

First Poster
Thank you all for the responses.
I'll try the reset for now, but this workaround is a bit weird....

@gchudnov wrote:
Thank you all for the responses.
I'll try the reset for now, but this workaround is a bit weird....

Yes, it is not acceptable that you need to restart the TV, but it beats typing a WiFi password every time.


samsung should make a os or firmware update as this is totally unacceptable.

This als happens on Ethernet. And local services, such as Plex, should not affect network connection.


I have had this issue twice.  The first time was about 6 months ago.  I tried all steps already mentioned, spent 5 hours total on the phone with Samsung going over and over the same steps without success.  I suggested several that maybe it was the NOC inside the TV - they insisted that was not the issue.  I finally removed the back, got the information from the NIC, ordered the part online for about $40, replced the old one, replaced the back of the Tv, and it worked.  It has worked fine for 6 months.  Now I am having a similar issue 

The first time the network wasn't found at all and the TV automatically switched to wired.  Replacing the NIC solved that issue.


Now it finds the network and asks for wifi password. I entered that correctly and it still does not connect.  All my other devices are connected. I have gone through manually setting the IP addres, Mask, etc.  and still can't connect.


I see suggestions on hereto disconnect the power from the TV for 2 minutes , I will try that.


Thansk for all the help

First Poster

i have the same issue as the OP described. Tried all the same steps as well. This is the 2nd time its happened. The first time comcast came out and replaced my router and samsung released a very new firmware at the exact same time so i'm not sure which fixed it (temporarily). But i will say this, i now have a TCL RokuTV that i just bought and it and the samsung are having the exact same issue. Connects to wifi fine, but fails to get out on the internet. I'm using a Cisco DPC3941B gateway from comcast all firewalls/device controls/etc are disabled. If i tether to my cell both tv's work fine. i took my samsung over to my neighbors house and it worked fine there as well (Consolidated Communications internet).

I'm wondering if its something to do with the mac address getting banned for some reason on comcasts network or at the gateway.

I have the same issue.

I hope your attemps worked. I played with mine for a few days.  The low and behold, it started working again.  

My 2nd tv has so far held the password 🤞🏻. However I followed advice on a bit forum and set up a 2 nd band width of 5mghz on my hub and connected only the tv to that. Still watching and waiting but hope this may be a fix. Apparently the 2.4 bandwidth may be picking up interference.
First Poster

I solved the problem without reset.

After some retries my TV connected to wi-fi router but still was not able to access the internet.

Then that I changed DNS-settings on TV to the fixed ones (set DNS-server to 

Next rebooted my router, and TV was able to connect to the internet.


Still, I'm not sure how long it will work without breaking again.

New Member

I had the same problem but after watching a video. I learned that holding the power button on the remote for a few seconds really helps. Hold down the power button on the remote and watch the power button light that is located on the bottom corner flicker a couple times, and that should do it. I don't know how or why but it helped me everytime it disconnected

First Poster
thanks for the replies, unfortunately resetting the tv via holding down the power button, factory reset, network reset, smart hub reset, unplugging it for 10 minutes all fail to fix the problem. I've also manually set DNS to and and that didn't help either. i've connected the tv directly via hardwire, directly to my comcast gateway's 2.4 and 5 ghz wireless channels as well as through a asus ac gt-5300 in wap mode and in wrt mode, none work. I can tether it to my smart phone or my wifes smart phone and it works fine.
Top Liked Authors