Support

Open search

Q80 keeps losing signal on BBC HD and I have to retune

Highlighted
First Poster

I have a 55" Q80 and all is well except that it keeps losing signal on my HD Freeview channels like BBC HD. They still appear in the guide and channel list but when I select them I get the No Signal error screen. If I retune it, then it finds all the channels including the HD ones and the signal is perfect. I've checked the self diagnosis and it even says signal strength of 100%. I appreciate this can fluctuate but why does the telly seem to get into a state where it no longer has the channel working. It's very frustrating and happens on average every 2-3 days. Once it happens it won't recover by itself and I have to retune again. The firmware is up to date. Please help?

3 REPLIES 3
Highlighted
SaudA Moderator
Moderator
Hi @LiamL

Does this only happen with specific HD Freeview channels? Can you also please confirm which country you're based?

Could you also confirm the current firmware version your TV is running? You can find the information in Menu > Support > Contact Samsung.
Highlighted
First Poster

It seems to happen to all the HD channels I have checked (I have not checked them all). But included are BBC1 HD, ITV HD and Channel 4 HD. I'm based in Surrey, UK.

 

It's the most up-to-date firmware. I checked.

Highlighted
SaudA Moderator
Moderator
Cheers for that.

Can you reset the TV by follow the steps on the guide below, and let me know if you still experience the same issue after this? http://spr.ly/6186EGY6K
Top Liked Authors