Support

Open search

Q7 led one connect box

First Poster

This tv is doing my head in. After recent storms my connect box got wet after water ran down the aerial. I have purchased  a replacement connect box and now the tv images are really badly pixelated. I have tried changing a lot of the settings and also had to reset the settings. Does the replacement box I’m using have to be same exact model. They only two things I can see different are the software version and date on the boxes. Any help would be appreciated before it goes to the skip... 

8 REPLIES 8
Apprentice

have you searched for a software/firmware update both on the tv and off the samsung website which you can load onto a memory stick and do a manual update...there may be a possibility that the tv  and one connect box software is clashing or mis-matched.

First Poster

Hello there, I’ve done what you said and there has been no change. The problem seems to be when the screen or images  is dark, at this point I’m not sure if it’s the screen refresh rate or something else. 

Highlighted
Apprentice

hi

does it happen on every source ?

dvd, 4k youtube video look ok or the same ?,or is it mainly via antenna/sat cable connections ?

First Poster

Hello, yeah its on every source whenever there are dark areas. I've even changed the one cable on the off chance that it was damaged and there's no change to the display. Had every lead out of the back to eliminate interference and it is still the same. Going to borrow another one connect box from a friend to see if that sorts it out,

Apprentice

fingers crossed its a faulty box...easier to replace than the whole tv at least. 

Apprentice
meant to ask before...have you gone into the tv menu and tried the picture test mode ?
First Poster
Hello if that's the that display the picture of the beach then its fine or is it supposed to cycle to another Image . Looks very impressive the problem seems to be when there are dark patches on the screen and or dark colours when it's really noticeable and the corruption is at its worst.
Apprentice

yeah..strange the internally generated pic is ok..like you say its really bright  which is good for colour and sharpness checks but not blacks.

im not a great techie but im sure all the video/processing electronics is in the connect box and basically the dispaly is just that...a display lol.

hope this other box is the fix.

Top Liked Authors