Support

Open search

Q60R QLED (55 inch) flicker with Nintendo Switch

Highlighted
SOLVED
Apprentice

TV does not work with Nintendo Switch, it starts to flicker every time I connect the console. It does not happen with FireStick TV or Chromecast, it's only with the Switch. Also the Switch works in other TVs (I have been using it until recently with another).

I have tried unplugging, plugging and restarting everything in every order imaginable, same results. 
I have tried using different ports, different HDMI cables, same results.
The TV is brand new (2 days) and the Nintendo Switch has all the original components. 

 

What is wrong here? Is the TV firmware incompatible with the console? I am seriously thinking about returning the TV.

Please help!?!?

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Moderator
Moderator

In you Switch System Settings, Go to TV output and change the RGB Range from Automatic to Limited. Does that fix the issue? 

View solution in original post

8 REPLIES 8
Highlighted
Moderator
Moderator

Hi @bfischetti. Can you confirm which software version you're running on your TV? This can be found by pressing Settings on your remote and going to Support > Software Update. 

Highlighted
Apprentice
Current version: 1352
it also says that the software is up to date.
Highlighted
Moderator
Moderator

Thanks, @bfischetti. I know you mentioned you've tried different cables already, were any of them similar to this? Only saying because a friend had a similar problem with their PS4. Used that cable and never had the problem again. 

Highlighted
Apprentice
No, none like that, but the point is that both HDMIs (the original one from Nintendo and a new one from Amazon Basics) work with the console on different TVs. There is no problem with the HDMIs or the console as far as I am concerned.
Highlighted
Apprentice

After reseting the TV and trying a few more things I have found that it does work on 720p, but not 1080p. What kind of 4k TV doesn't work with a Full HD setting? I am very disappointed. 

Highlighted
Moderator
Moderator

In you Switch System Settings, Go to TV output and change the RGB Range from Automatic to Limited. Does that fix the issue? 

View solution in original post

Highlighted
Apprentice
That fixes the issue! Any idea why we have to restrict the RGB range for it to work properly?
Highlighted
New Member

This worked for me, thanks. I turned off auto on both of the TV settings on my Switch and now it works. 

Top Liked Authors