Support

Open search

New Samsung Q8C Unable to Find Sky HD+ Box

New Member

We recently bought a Samsung Q8 TV and are trying to get the Sky box connected to it. It has managed to find free channels but when we've plugged the HDMI from the Sky box into the One Connect it just comes up as 'Unknown' and when you click it it says 'No Signal.' The Sky box is definitely turned on and worked fine with our last Smart TV with the same HDMI. While watching regular free channels on the 'TV' part, for a while it kept flicking to a screen saying 'Scanning for devices... You can easily control the detected devices with your Smart Remote', and then saying 'No device detected' and then the free channel comes back on and it does that again. Kept doing that for about an hour before I managed to get it to stop. Unsure how to make it recognise the Sky box? There must be some settings I'm missing somewhere. TV model QE65Q8CAM. I've tried unplugging and replugging everything. It recognises that there's something in HDMI1 although next to the symbol where it says Unknown is a red power icon, as though it's saying the Sky box is not turned on, when it definitely is. I have also tried turning HDMI UHD Colour on/off, if this makes any difference (seen it mentioned in a different post), and also turned the Anynet+ (HDMI-CEC) off too but that made no difference. Any suggestions on things we can try would be appreciated.

4 REPLIES 4
New Member

I have a very similar problem. Did you get a solution?

Superuser I
Superuser I

@Chris1234wrote:

I have a very similar problem. Did you get a solution?


@Chris1234 Do you also  have issue with signal on Sky Box?  Ensure you have the latest firmare  UHD is only available with SkyQ (which I've had wee while) and as you have Sky HD+ you would need to ensure UHD colour is off on that port and try the different settings that were already mentioned with CEC Anytime Net  if still to do so.    If still problems can you try another port?  Have seen following advice  : 

 

 Try a hard reboot on the TV by leaving its power cord unplugged for 10+minutes while all the HDMI ports are unplugged completely, I would also reboot the  Sky Box. Another recommended solution is a full factory reset via the TV's service menu.   Should it be issue with  with controlling Sky with the Samsung remote see my post here https://eu.community.samsung.com/t5/TV-Audio-Video/Smart-hub-update-ue48ju7000/m-p/440316#M10224

 

 

Highlighted
New Member

Hi I had the same problem with my Sky Q box for about 5 months. Sky have replaced the box twice bit the problem still continued. I contacted Sky as I'm not willing to pay for a service that I consider is not working. They sent out another engineer who replaced the sky q box which was a model 2 with a model 1 and its now working perfectly fine. 

Superuser I
Superuser I

@HowlingBadger wrote:

Hi I had the same problem with my Sky Q box for about 5 months. Sky have replaced the box twice bit the problem still continued. I contacted Sky as I'm not willing to pay for a service that I consider is not working. They sent out another engineer who replaced the sky q box which was a model 2 with a model 1 and its now working perfectly fine. 


Hi @HowlingBadger ,   Obviously taken a while but glad  the issue has been resolved.    Not had a problem  myself but have heard previously of some Samsung TV owners having issues with the 2nd generation SkyQ Box, so may be worth reiterating this point if difficulties persist.

Top Liked Authors