Support

Open search

New Apple TV and Airplay firmware update not available?

Apprentice

The new firmware for the 2018 and 2019 Samsung TVs to support Airplay 2 and the Apple TV app has been announced and plenty of people have posted photos of it working. But my TV can't seem to find an update from its current v. 1251 firmware. And the support pages on the Samsung website don't list a newer firmware. Anyone had success getting this update?

115 REPLIES 115
DannyT Moderator
Moderator
Hi there, @Saracen.

On most of our TVs, that's the update that you need! Could we first just double check what TV you're using?

If you can't find the Apple TV app in recommended apps, then we'd advise a Soft Reset of the Smart Hub. You can do this by going to Settings > Support > Self Diagnosis > Smart Hub Reset.

MCU.jpg


 Welcome to the Community! :smileyhappy:

Apprentice

I also have an issue with my tv (ue43nu7092). I dont see the appletv app nor i have received any firmware updates

(Greece)

Superuser I
Superuser I
Observer

it is written ERR30001

 

What is it?

Observer

is model UE65NU7099 supported????!

Apprentice

Interesting: when I got home it was all working with Airplay visible on my iPhone and the Apple TV app already installed firmware is still 1251 so I guess that wasn’t the issue, just waiting for the push from Samsung. Mine is an NU8000 BTW.

 

Thanks for the tips!

Apprentice
Interestingly the TV only shows up as an AirPlay destination when powered on. Unlike the actual Apple TV that can always be woken up with Airplay.
New Member

I have a 

75" Class Q7FN QLED.. and I tried the reset as recommended above and the app isn’t available. The update says I’m running 1262.  As long time iOS user I as pumped to hear th news, but nada. Please help. 

 

 

First Poster

I have a 43NU6900 4K which is listed as one of the models that should be getting the Apple TV app but I still don't have it. Firmware is up to date and I tried resetting SmartHub but nothing chaged. Any ideas?

Top Liked Authors