Support

Open search

BBC iPlayer, News and Sports Apps won't play video on UE55MU6500

Explorer

I recently bought a UE55MU6500 Smart TV and am generally happy with the picture and performance.

It is running the latest firmware (1138) and I have had no problems with blank screens etc.

 

However there are a few apps that don't work and I am having to use an Amazon Fire TV box to watch them, which isn't really the point of a brand new Smart TV.

 

So, Netflix, NOWTV, Google Play, Amazon Video,  4OD and ITV Hub all work well but My5 and any of the BBC apps - iPlayer, BBC News and BBC Sport all start OK but when I select a video/programme they won't play.

(I have Apple TV, Now TV box and Amazon Fire TV box and all of them run all the apps (where available))

 

The BBC apps spin the buffering wheel for some time then give an error 02001 stating it is a temporary problem try again, My5 just says Whoops.

 

The iPlayer app is version 1.1.3, the app itself says it is version 4.6.29.1 built on 31st August 2017

The iPlayer app does not offer an option to Sign Up which I  think is unusual as all other versions I have seen do.

 

I have logged this with Samsung support (**********) so I have gone through resetting the smart hub, the whole tv, re-entering all the login information several times. I even tried starting the app after watching live standard definition tv rather than HD channels. I have left the power off over night.  I have checked notifications for any new versions of apps and I have reinstalled any and all apps I could find. I have used WiFi and wired connections

 

I did  request support via the tv and Samsung did return my call - but I was out at the time.

 

So does anyone have an MU6 series with a working iPlayer app or have any ideas on whether the app should actually work and if the TV/app is registerd with the BBC?

 

Thanks in advance for any help.

 
 
13 REPLIES 13
ChrisM Moderator
Moderator

Hi @loftygit.

 

Having just checked the software of your TV, we can see an update is available to version 1141.0, released on 6th Sept '17. Could you check to see if the update's available OTA? Go to Home > Settings > Support > Software Update > Update Now. If not, you can download the update to USB here.

Explorer

Hi ChrisM,

 

Thanks for the reply and the heads up on the new version of firmware. I downloaded and installed it and everything is still the same. I have left the power off for a while to allow things to settle, but I have not yet reset the smart hub, though I am getting quicker at reentering login details so will try shortly.

 

I don't know what has been fixed in this release, but the BBC iPlayer app is still the same version number and still doesn't allow account logins. The My5 app still won't play programmes either.

 

Is there anyway of finding out what is actually happening, I would turn on logging on my router but it is a BT Hub so its not easy.

 

Thanks for your help so far.

 

 

KellyM Moderator
Moderator

Hey @loftygit,

 

If possible, can you setup your phone as a Wi-Fi Hotspot and test the Smart Hub features again? This will help us to determine whether the problem is related to the internet connection that you are using. 

 

Have you tried changing the DNS settings at all? 

Explorer

Hi KellyM,

 

Thanks for your reply.

 

I have just tested the Smart Hub using my iPhone as a hotspot, I only have a weak 3G signal but it seemed enough for a connection.

 

I could connect to the iPlayer, My5, ITV and Netflix apps but I still got the errors trying to play programmes from iPlayer and My5. Netflix tried but couldn't get a full buffer.

 

I tried personal and BT router with automatic and 8.8.8.8 DNS with the same errors. I have also tried wired and wifi in the past.

 

From other threads and websites I can see that there have been issues with iPlayer on Samsung TVs before, I am hopeful that there will be a solution before ( as for 2010 TVs) the app is taken out of support. 8-)

 

Thanks for your help so far.

Explorer

Hi Mods and experts,

 

Any more ideas to try or any news on new versions of apps/widgets/firmware?

 

I understand there is a factory reset option on the engineers menu, is that any different from the smart hub resets?

 

Does anyone have iPlayer working on a 2017 smart TV?

 

Thanks everyone.

Explorer

Just installed the latest firmware 1144 and the problem still exists. I can't watch any BBC programmes from any of the BBC apps nor the My5 programmes.

 

The version of the BBC app is still 1.3.1 though the date on the BBC help page seems to have changed. 

 

There are no Samsung 2017 models listed on the Samsung BBC iPlayer Certified Devices page. Is this a problem with Samsung or the BBC?

 

Thanks for any help with this.

First Poster

Hi.  Does anyone have an update on this? I have exactly the same problem on my new Samsung UE49MU7070 everything works fine apart from BBC iPlayer which hangs with error 02001 every time. I’ve tried smart hub reset, factory reset, app update, router reboot, tv reboot, contacted both iPlayer and Samsung support all without resolution.  Firmware at v1044 and iplayer software are both right up to date. Worked fine first 2 weeks after purchase.  IPlayer works well on separate new Samsung Blu-ray player but not the new tv. I’m now thinking it might be broadband related (which is excellent) but I don’t know anything about DNS and other settings.  Am I missing something really obvious?  Any pointers would be appreciated, thanks. 

Explorer

I have just installed the latest firmware 1145.1 and the problem still exists.

 

The iplayer version is still the same and does not ask for a Sign In, is this the problem?

 

Thanks for any insight.

Explorer
The iPlayer now allows me to Sign in but still the same result, now on Firmware 1151.1
Top Liked Authors