Support

Open search

Amazon Fire Stick

Highlighted
SOLVED
New Member

Cannot get Amazon Firestick to work properly on my new 49inch Samsung model Ue49k5500. Are there issues with this equipment?

1 ACCEPTED SOLUTION

Accepted Solutions
Apprentice

Hi ChrisM, Yes, basically my own ignorance of how the tv operates! I thought I needed the Firestick to be in the tv to receive Amazon videos etc. I didn't realise I only had to sign in as I was already a subscriber via the stick. D'oh!

27 REPLIES 27
KellyM Moderator
Moderator

Hi @Robtait,

 

We're not aware of any issues. 

 

Can you tell us a little more about the problems you're having with it? Are you receiving any error messages? Does it work well when connected to a different TV?

Apprentice

Don't have an answer but I have just bought the same tv and keep getting the 'No Signal' message. Seems it's not registering in HDM1/2/3 at all.

ChrisM Moderator
Moderator

Hi @Libby.

 

Do you have a different TV you can try the Firestick in?

 

Does anything else work in the HDMI ports of your UE49K5500?

 

 

Apprentice

Hi, I have the problem sorted out now. Thank you for your reply, ChrisM.

ChrisM Moderator
Moderator

No problem @Libby.

 

Could we ask what was causing the issue?

Apprentice

Hi ChrisM, Yes, basically my own ignorance of how the tv operates! I thought I needed the Firestick to be in the tv to receive Amazon videos etc. I didn't realise I only had to sign in as I was already a subscriber via the stick. D'oh!

New Member
I have the same issue with a firestick and a ks8000 tv wih the one connect hdmi hub
The firestick works on my ks8500on connect hub. Very frustrating, amazon says its a samsung issue, samsung says its a amazon issue
New Member
Yes, We have tried 3 firestick a. Samsung will not recognize the stick. It will recognize the Wii plugged into the same HDMI port. It worked for a short time and then ran the latest update on the TV and it was gone again.
New Member

I just got the new Q7F. The box will not recognize my fire stick. Is there a step I am missing in the setup?

Top Liked Authors