Open search

All4 Apps not working

First Poster


cant get my All4 app to play any programmes

CarlH Moderator

Hi @Julesdiamond. Did you reset your SmartHub? 


@381JG wrote:

I have the same problem that Reset Smart Hub is greyed out, surely someone must have a solution.

I had the same greyed out issue, but that was because I still had 'SmartHub open,

Close SmartHub and then access 'Menu.


However, in my case, resetting the Smarthub failed to improve the situation.

New Member

Me too it just says it’s already up to date and continues not to work.

New Member

I I have reset the Hub change my password on all4 signed out of everything and sign back in again and still it will not work on Channel 4 I can all I can see is a black screen and the audio is is working

Looks like All4 have 'upgraded' :-) their app to version 4.406 from 6.009 so is now working again until they auto-update again. Probably going to do some decent testing. Fill your boots while you can.

Same with me.  Sound but only got black screen.  Have reset hub - no difference.  Was working ok until halfway through an episode last night.  All other apps are working.  Any help would be appreciated.

First Poster
I have the same with only All4, sound but no picture. Have reset smart hub and set up again but it's still not working.
Samsung please help with this.

I had this problem and reported it to both Samsung and All4.  After a few weeks I received this from All4 which I actioned and the App is now working:  Hope this helps.


Dear David,

Thank you for your patience while we look into this matter.

We would advise that we have since released a new All 4 update for Samsung TV that should resolve some of the issues you were experiencing previously. We would recommend you follow the previously advised troubleshooting once again, to ensure All 4 is fully optimised on your Samsung TV. We have included these steps again below for your convenience:

  • Please ensure your firmware is up to date. Manually updating the firmware   i.e. go onto the Samsung website, find the latest file, download onto USB is the best way to check this. Automatic updates do not find the most recent firmware sometimes, and so out of date versions can cause issues. 
  • Reset the smart hub from your TV settings. To do this go to Go to settings  > Go to support  > Go to Self Diagnosis  > Select Reset  Smart Hub. (Please note this will update all apps on your TV and you may have to log in on other services again).
  • Please ensure you have the most up to date version of the All4 app installed ? this can be found on the Help & info section on your TV.
  • Reboot your television set and Internet modem, by powering them down for 60 seconds and switching them back on.

If, after taking these steps the issues continue, please let us know and we will re-escalate this to the responsible team within All 4.

Kind Regards,
Siobhan Dickson
All 4 Support
New Member

Followed all of those steps, still not working. All I did was move my SMART TV from one address to another and connected it to a new modem. Absolutely no need for All4 to have a supreme knickerfit. All other apps are working just fine, despite me having to reset the hub and re-log into them all in the vain hopes that All4 might deign to do a wee bit more than play two adverts before transmitting a plain, black screen. Any ideas or contact details for All4?

Top Liked Authors