Open search

All4 Apps not working - SmartHub Reset not a fix


Samsung TV eu32es6800uxxu

Updated All4 app at prompt.

I can access All4 to see programme options. I can select any programme, but all programmes fail to load and start. There is a continuous four dots flashing and nothing ever happens.


Tried: Exit SmartHub. Menu > Settings > SmartHub > SReset SmartHub.

Entered all pin etc. Reconnect to my broadband hub. ect etc.

Firmware apparently all up to date.

Still nothing working.

Restart TV.   No joy.

Ended up creating a password etc for something to do with the new app - no idea what it is for, but hoping it would get around some stupid glitch, but nothing is working.


Hopefully this is something that can be fixed in the firmware and also hope I'm not waiting too long for the fix.


I contacted All4, they are aware and are looking for a fix.


We can advise that we are aware of this issue affecting viewers using Samsung TV's to watch All4. Our engineers are currently investigating this issue and hope to have this resolved as soon as possible.


We apologise for the disruption to your service and appreciate your patience while our team work to resolve the problem.


Kind Regards,  

Alex Groves

All 4 Support


Cheers for the heads up.

There are a few topics in this forum relating to this issue, which may have a solution for some people, but within those 'Solved' topics there are alot of people for whom it does not work.


We'll have to be patient, but hopefully not too long


Yes tried resetting, updating, reinstalling before contacting them, seems to me that they have had a major upgrade and failed to test it correctly.


Shall wait and see how important it is for them to correct this.

Looks like All4 have 'upgraded' :-) their app to version 4.406 from 6.009 so is now working again until they auto-update again. Probably going to do some decent testing. Fill your boots while you can.

I just got a 43inch smart telly a month back. (Mid november)  the UE43NU7470U Model.


Ive only recently started actually using the ALL4 app.  I had a Misfits marathon over the weekend.  Or tried to. Until Sunday when it froze.  I googled, and found advice to reset the apps.... so I did... re logging in to all of the ones requiring it.... ( All 4, My5, NOW TV etc)


Just watched  an episode of Misfits this morning...  and when it was time to start the next one... it all froze up.

This doesn't appear to have been fixed :(

Works perfectly fine as an APP on my NOW TV box on my other telly, so im guessing it HAS to be an issue with the Samsung TV version of the app.  


Pretty poor show considering there is no alternative ( other than plugging in an external (nowtv type) box



Hi everyone, heads up....All4 have updated again to version 6.211 and everything has failed again.
Resetiing hub etc etc is not working; are we surprised!
I contacted All4 people regarding issue. Checked again today and another app update was available. Updated, but it seems to have rolled back to version 4.40601 and reverted to original layout. All is working again - yehar, so the All4 people seem to be on the ball.
Top Liked Authors