Support

Open search

Airplay 2 not showing settings

Highlighted
SOLVED
Apprentice

Hi Guys,

 

Just got 2019 q90r and updated to firmware 1303. When I try to use airplay TV shows up on iphone/ipad as available device and when I try to connect it asks for code. Yet my TV does not display the code. If I go to General -> Airplay Settings I just get black screen.

 

Any ideas?

 

Thanks in advance

 

Andrew

1 ACCEPTED SOLUTION

Accepted Solutions
Apprentice

For anyone having the same problem I've managed to fix it myself. Most likely you have some custom DNS resolver like pfblockerng or pi-hole or something similar that blocks ads. It seems that this also blocks airplay form working as airplay device needs connection to apple servers in order to work. To get it going you need to whitelist this domain: mediaservices.cdn-apple.com

 

Hope this helps

3 REPLIES 3
AndrewL Moderator
Moderator
@AndrewIRL: Please can you try switching off your TV at the plug and switching it back on to refresh the software. Once complete, go to Settings > General > Airplay Settings and disable the 'Require Code' option. Hope this helps.
Apprentice

Hi Andrew

 

ive tried that but result is the same . When I go to AirPlay settings I get a black screen

 

edit:

tried to reset tv as well but same result 

Apprentice

For anyone having the same problem I've managed to fix it myself. Most likely you have some custom DNS resolver like pfblockerng or pi-hole or something similar that blocks ads. It seems that this also blocks airplay form working as airplay device needs connection to apple servers in order to work. To get it going you need to whitelist this domain: mediaservices.cdn-apple.com

 

Hope this helps

Top Liked Authors