Support

Open search

Airplay 2 not showing settings

Highlighted
SOLVED
Apprentice

Hi Guys,

 

Just got 2019 q90r and updated to firmware 1303. When I try to use airplay TV shows up on iphone/ipad as available device and when I try to connect it asks for code. Yet my TV does not display the code. If I go to General -> Airplay Settings I just get black screen.

 

Any ideas?

 

Thanks in advance

 

Andrew

1 ACCEPTED SOLUTION

Accepted Solutions
Apprentice

For anyone having the same problem I've managed to fix it myself. Most likely you have some custom DNS resolver like pfblockerng or pi-hole or something similar that blocks ads. It seems that this also blocks airplay form working as airplay device needs connection to apple servers in order to work. To get it going you need to whitelist this domain: mediaservices.cdn-apple.com

 

Hope this helps

5 REPLIES 5
AndrewL Moderator
Moderator
@AndrewIRL: Please can you try switching off your TV at the plug and switching it back on to refresh the software. Once complete, go to Settings > General > Airplay Settings and disable the 'Require Code' option. Hope this helps.
Apprentice

Hi Andrew

 

ive tried that but result is the same . When I go to AirPlay settings I get a black screen

 

edit:

tried to reset tv as well but same result 

Apprentice

For anyone having the same problem I've managed to fix it myself. Most likely you have some custom DNS resolver like pfblockerng or pi-hole or something similar that blocks ads. It seems that this also blocks airplay form working as airplay device needs connection to apple servers in order to work. To get it going you need to whitelist this domain: mediaservices.cdn-apple.com

 

Hope this helps

First Poster

I have a brandnew 2019 Q60R 49" with software version 1318 to which I updated recently. TV and my ipad (ios 12.4.1) are on the same network, ipad shows tv in airplay dropbox. However, tv does not generate a code. When I try to open airplay settings on tv, tv screen gets black and nothing is shown... Sometimes airplay settings option on tv is grey-out. Any help is appreciated.

 

I tried it first on a LAN without internet access, then tried again by connecting my ipad and tv to my mobile phone's hotspot (internet sharing). I had no chance on both. Ipad lists the tv but tv shows nothing when I get in airplay settings.

 

I checked apple's FAQ site, it says "airplay doesn't need internet access". I couldn't understand the suggested solution. TV's DNS and IP settings are "auto". Where to look for whitelisting the domain you suggested?

 

On the other hand, evenif LAN is not working, I think tv has to show at least airplay settings. Am I right?

 

First Poster

FOUND THE SOLUTION !!!

If all the solutions above didn't work for try this.

1) Go into your router's settings and find Virtual DMZ ( Wan DMZ or DMZ Host )
This setting seldom sits under Firewall Sets or Wan Sets. Every brand/model router's user interface is different, so check yours in Internet.  
This video should give you enough idea about the process
https://youtu.be/dTvh1FnboU4?t=64

2) Assign a port for DMZ : 192.168.1.200 as example.

It should be in the same domain as your router.
Mine sits on 192.168.1.1 so I used the first 192.168.1.[enter a number between 2-255 ] 
As long as this address doesnt get conflicted with another device's IP adress you are good.

3) Assign the same IP to the Samsung Smart TV 
In this example, we have to assign the same IP to Samsung TV so it will be a DMZ Host.

4) Send "Thanks you broo" mails to omer.can.atakol@gmail.com ^^

5) If you don't get any of this find someone who plays online games in PS4, they will understand/help what you try to do
This is a pretty standart operation if you want to play multiplayer games in PS4, any Fifa
, NBA, Call of Duty or Battlefield 

player would help you.


Caution: What DMZ does is it gets your TV beyond all the firewall of the network. 
I got no problem with this, but I would like to hear safer solution as well ^^

Top Liked Authors