Support

Open search

58NU7100 dark HDR scenes are too dark

Apprentice

The HDR mode intends to improve dark scenes pictures, but due to the global dimming algoritm that Samsung implemented it is impossible to see HDR movies with dark scenes.
I have disabled all image post processing, switched all ECO modes, but it still dimming on dark scenes. Dаmn, its drives me crazy. Especially you can see that when you open setting menu over dark scene. You can see how it increases the light because the menu is white, but once you close it it decreaces it and again everythig is dark.

Going to return this tv.

4 REPLIES 4
First Poster

Had the same problem.
I decided to turn off the "Auto Detect Lighting" and "Eco Settings".
Contrast set at 18-22; backlight 40, brightness -1/0.
And turned off HDR on TV box. I am satisfied with the result.

Apprentice

The changes that you did will not prevent from global dimming. You will still get it even in SDR mode.  And i think samsung will lnever fix or provide option to disable it. This dimming was introdused intentionally to downgrade value of Series 7 and make series 8 more attractive. 

New Member

Change Settings>General>External Device Manager> HDMI Black Level to Low

Apprentice

Wrong. 

This option enabled only for hdmi inputs and compensate rgb range for old external devices. It has nothing to do with backlight dimming and this option disabled for smart apps and tv signal.

Top Liked Authors