Support

Open search

2018 QLED HDMI issues with AV receiver.

Apprentice

Hi, I purchased a new Yamaha AV receiver last week and its been driving me potty trying to get this to work with my 6 week old QE75Q9FNAT tv. The AV receiver plugs in to HDMI 4 on the one connect box with all sources plugging into the Yamaha and that doing all the switching of the picture and sound.

 

The receiver is set to pass through and the HDMI handshakes with the TV and plays the video. The problem is that when you change a source on the receiver and it changes resolution (i.e. 1080p to 4K HDR) it looses the handshake and cant reconnect the HDMI. That is until you power it all down and physically unplug the hdmi lead in the one connect and reconnect it, then when its powered up it will work again until he source resolution is changed.

 

The issue seems to be when the tv tries to detect the new 10bit HDR source a big blue splash screen appears telling me its changing the display and then HDMI then cant handshake again. I've tried loads of things including about 9 different HDMI leads been on the phone to Yamaha tech support who are superb (lesson to be learnt here Samsung).

 

The system is fine switching between 4k HDR from SKY Q and the Nvidia Sheild as the sources are the same and it will even switch to the 1080p Playstation 4 fine. Going back from the PS4 to a 4k HDR (10Bit) source the HDMI hangs after the TV comes up with the detecting source message. The issue seems to be with 10Bit colour signals where the problem is as 8 bit is processed fine and the TV doesnt do anything.

 

I've tried lots of different settings including turning off HDMI auto detect which works, the problem is this doesnt stay in the mode you set it to and when the TV turns off it defaults to back on. This should be an option in the menu and not a trick you have to learn about from the internet. HDMI-CEC has been tried on and off and doesnt make and difference, ive left it off for now.

 

Is there a way to stop the tv trying to detect the source and process it after all its all coming through HDMI port4 (the other ports all act the same). Or to permantly set HDMI auto detect to off. I just want it to act as a display for the signal from the receiver and do nothing else. At the minute im disconnecting and reconnecting the HDMI port about 5 time a day at the moment to get the connection back.

 

Ive spoken to tech support who are abroad somewhere and they really dont understand what I'm saying even telling me at one point the display doesnt support 10 bit colour signals.

13 REPLIES 13
First Poster

I've also run into HDMI handshake issues with the Q9FN. I've replaced my old Panasonic LCD TV with a spanking-new Samsung Q9FN, and now I find that the HDMI handshake between my trusty Denon AVR-3808 and the Q9FN just doesn't work. As long as I don't turn on my HTPC (an Intel NUC running Windows 10 and Plex client), then I get the Denon onscreen display, and I can walk through the Denon menus.

However, booting up the HTPC causes the Q9FN to complain that there is no signal present.

I've tried connecting the HTPC directly to the Q9FN, and using an optical link back to the Denon for sound. This works, but unfortunately, a lot of my movies use DTS-HD for audio - and Samsung seem to have dropped support for this in the Q9FN, so I get no sound. I seem to be between a rock and a hard place here. Any suggestions? Thanks.

Apprentice

I can't believe for such an expensive TV that there are threse issues . Samsung have just said oh well the devices aren't compatible. Not really acceptable for one of the biggest AV receiver manufacturers (same as not acceptable for Denon either).

 

I have found that if I have a 10bit HDR device plugged directly into the one connect box (HDMI 1). While the receiver is unable to handshake on HDMI 4 of the OCB with it source and the TV selected to HDMI 4 so no picture. If I then turn on the device in HDMI 1 the whole OCB becomes receptive to 10 bit signals and the receiver will handshake automatically. 

Apprentice
To be fair if your TV is giving Ng you a message unable to connect that could be the HDMI leads not up to the job. Get the Amazon basic HDMI leads as they work well.
First Poster

I've discovered what the problem was. My old Denon AV-3808 is HD-only (1920x1080 resolution), so in the Q9FN settings, I had left the UHD setting unchecked. That is what caused the handshake to fail. Setting UHD on, and the handshake proceeds to completion and the Denon connects and shows the display. Seems completely illogical, but there you go...

Apprentice

Just to update my original thread. I did get a solution in the end to make the Yamaha reciever and Samsung TV work properly. It seems that Samsung dont use standard EDIDs on their HDMI inteface and as they are modified the Yamaha wont handshake. I purchased a HD Fury Integral that acts like a middleman and send the correct EDID to both devices they will then send and recieve a full 10 bit picture correctly. I have to have ARC turned off on the TV though as the telly throws a wobbly with ARC set on. The rest of the system works with ARC fine though.

First Poster

If problem is windows->Reciever->Samsung TV then its quite easy to fix.  Download Custom Resolution Utility (CRU) 1.4.1 and Monitor Assist from Entech. Connect pc directly to Samsung and extract EDID info with monitor assist, do same with AVR. Compare the two. Open Cru (run as admin). Most likely your problem is under Extension block CEA-862 Detailed Resolution.. correct timing info and resolutions and hit the copy button on top of Extension block window and then in main CRU window (doing this copy new EDID info to registry).  Restart PC..  NB you find a lot of info in the CRU FAQ. This fixed all my problems regarding HDMI handshake. Problem was my new Pioneer reciever and not Samsung.  

 

 

First Poster

Read my post above.  Your problem is most likely the reciever. :-)

First Poster

Hi everyone  I would just like to share this with you all  I have a Q9FN and a Marantz 1609  I have all HDMI components going through the receiver apart from the PlayStation so that is the skybox 4K Blu-ray player and then arc to tv  when I play 4K Blu-ray the Arc  back to the receiver shows that it is playing Dolby Atmos true HD you can even switch it from that to Dolby digital true HD  all 4K picture quality is working as it should all sound quality for Dolby Atmos is working as it should Samsung must’ve fixed   The ability to  audio return  Dolby true HD through ARC  because Dolby true HD is only supposed to work on eARC  The skybox has Dolby Atmos and that works through Dolby Digital plus signal the same as Netflix  I hope this helps people struggling to get the sound quality through Ark on the receivers 

New Member

You will never find a fix Samsung just lie most Samsung tv have a issue with the Key word is  [receiver }. And to be fair some sound bars even if it’s there own make ie Samsung. I have in all rooms a Samsung tv all 4K UHD now if you’re  receiver  Has arc not your tv your receiver then you may be fine but my Samsung receiver home  theatre doesn’t have for months all have been working fine until one day the any-net + stopped working got that back working but still now sound on receiver. Call Samsung they send out 3 people each on different days and dates no1 can fix it they changed the one connect and the main  borad inside still not working so they bring there sound bar and connect the SB to the arc on the tv and the new sound bar has arc works fine but I don’t have a sound bar I have a Samsung receiver/ home Theatre system guy tells me that it’s my old receiver it’s 8 years old and it was working fine but not now and it works fine  by it’s self playing music or watching a DVD 

Top Liked Authors