Support

Open search

iPlayer HLG/UHD HDR on Samsung’s J and K Series TVs

Navigator

Aha thanks mate

Voyager

Yay!

Well that was great.  Fantastic picture and smoothness for 99.9% of the match.  Had one glitch where got error message but sorted itself out quickly.

Highlighted
Voyager

@crashcris wrote:

@ne_on wrote:

Guys I don’t mean to sound stupid but someone mentioned setting chroma subsampling to 4.2.2. How do I even do this?


On the Roku SS+ . Settings- System- Advanced system settings-Advanced display settings- HDR subsampling-4:2:2.


Are the BBC even broadcasting in 4:2:2?  If not, what’s the point in setting the Roku to output 4:2:2?

Voyager

I must say, all those midges look terrifying in UHD.

Pathfinder

@dunwell wrote:

@Moily

 

I've settled on 63 for the Colour as the reds were just a bit too vivid at 70. But it looks great so thanks again.


Just realised the HDR sampling on mine was on 4:2:0, changed to 4:2:2 and the colour boosted significantly so had to dial it back down to 50.  Only change from AVF settings was Warm2 to Warm1.

Navigator

So what’s the status after today’s game? 

Is everyone still saying gamma -3 and colour bumped up?

Voyager

@ne_on wrote:

So what’s the status after today’s game? 

Is everyone still saying gamma -3 and colour bumped up?


I’ve never had to bump up the colour, just gamma to -3 to help compensate for the wrong gamma curve.  If the colours look pale, try setting Colour Space to Custom. Looks like there may be a bug with the TV randomly using the wrong colour space on WCG HDR content - I’ve now seen this happen randomly on both the TVs media player and also on HDMI inputs.

Voyager

@tarbat

 

Is this bug directly causing the “wrong gamma curve” issue?

 

Since I fixed the random colour space issue I’ve put gamma back to zero and it looks brilliant. 

Voyager

@Moily wrote: 
Just realised the HDR sampling on mine was on 4:2:0, changed to 4:2:2 and the colour boosted significantly so had to dial it back down to 50.

Interesting that switching from 4:2:0 to 4:2:2 boosted colour saturation. Surely that must be a bug either in the Roku, or more likely the TV.

 


@Jep_uk wrote:

Nice one about ps4. Watching it now. Had to put it on game mode as seemed to have stutter. Also colour was washed out, had to ramp up colour to 65 and now got it on native. 


Disable Auto Motion Plus.

Top Liked Authors