Support

Open search

Upside down, fuzzy picture, no hdmis working

New Member

Hey Guys, 

 

First time poster. Need some support. 

 

Last night (Christmas night !!!) I plugged in my sons new PS4, after this all the problems started. At first, sound was coming through the tv, but no picture. I then disconnected the ps4, tried in another tv and all is fine. 

 

Then i I tried to reconnect my other devices which were working 10 minutes before (sky Q and a fire stick). None of the devices were being picked up via HDMI, it recognised Almost that they were connected but no signal error. 

 

I tried everyrhing you you can imagine, reset all devices multiple times including the tv, tried different hdmi cables, nothing. I then entered engineer mode and performed multiple factory tv resets, still nothing. 

 

Then this morning, I turned the tv on and the picture is upside down and back to front ! The same messages appear (no signal) but it is in the above state. Also, the picture is quite fuzzy. 

 

Couple of things, tv is around 7 years old, model code is UE40C6540SKXXU. 

 

It hasbt been connected to the internet ever, and in this state I don’t think I could even navigate a menu even if it was hard wired. 

 

Contacted Samsung support over the phone and they can do nothing as it’s not connected to the internet. 

 

So, is it absolute broken, or even if someone has seen something simalar and provide clarification on what hardware isssue I am experiencing. Any comments are much appreciated. 

 

Thanks

 

scott. 

 

 

2 REPLIES 2
Black Belt 

@ScottBrazil wrote:

Hey Guys, 

 

First time poster. Need some support. 

 

Last night (Christmas night !!!) I plugged in my sons new PS4, after this all the problems started. At first, sound was coming through the tv, but no picture. I then disconnected the ps4, tried in another tv and all is fine. 

 

Then i I tried to reconnect my other devices which were working 10 minutes before (sky Q and a fire stick). None of the devices were being picked up via HDMI, it recognised Almost that they were connected but no signal error. 

 

I tried everyrhing you you can imagine, reset all devices multiple times including the tv, tried different hdmi cables, nothing. I then entered engineer mode and performed multiple factory tv resets, still nothing. 

 

Then this morning, I turned the tv on and the picture is upside down and back to front ! The same messages appear (no signal) but it is in the above state. Also, the picture is quite fuzzy. 

 

Couple of things, tv is around 7 years old, model code is UE40C6540SKXXU. 

 

It hasbt been connected to the internet ever, and in this state I don’t think I could even navigate a menu even if it was hard wired. 

 

Contacted Samsung support over the phone and they can do nothing as it’s not connected to the internet. 

 

So, is it absolute broken, or even if someone has seen something simalar and provide clarification on what hardware isssue I am experiencing. Any comments are much appreciated. 

 

Thanks

 

scott. 

 

I think a visit to richer sounds in the boxing Day sales. 


New Member
I did think that tbh 😂

Just after Christmas isn’t the time to drop £££ on a new tv tbh.
Top Liked Authors