Support

Open search

UVD-K8500 issues with 4K movies

SOLVED
Apprentice

I am hoping someone can help me here.  I have the Samsung UVD-K8500 and have just started encountering problems with playing some 4K moview.  I purchased Thor Ragnarock and Avengers: Infinity War 4K versions.  I attempted to play the 4K version of these movies and they will not play.  The player recognizes the disc and tries to load it but it gets stuck at the loading prompt. The screen goes black and the upper right corner the loading icon is spinning.   The player locks up and none of the functions work after the movie starts to load. I have to turn off the player to get it to eject, and it takes a long time (3-4 minutes and longer) to get the player to power off.  I have put in other 4K movies and they play fine, the blue ray play fine.  it appears to be something with these specific Marvel movies that I can tell.  I have not gone through my entier 4K library but have pulled a sample of about 10 different movies, some true 4K and some remastered, and have not encountered this.  Does anyone have any thoughts on what the problem could be?

1 ACCEPTED SOLUTION

Accepted Solutions
Superuser I
Superuser I

@LTRUMAN wrote:

I am hoping someone can help me here.  I have the Samsung UVD-K8500 and have just started encountering problems with playing some 4K moview.  I purchased Thor Ragnarock and Avengers: Infinity War 4K versions.  I attempted to play the 4K version of these movies and they will not play.  The player recognizes the disc and tries to load it but it gets stuck at the loading prompt. The screen goes black and the upper right corner the loading icon is spinning.   The player locks up and none of the functions work after the movie starts to load. I have to turn off the player to get it to eject, and it takes a long time (3-4 minutes and longer) to get the player to power off.  I have put in other 4K movies and they play fine, the blue ray play fine.  it appears to be something with these specific Marvel movies that I can tell.  I have not gone through my entier 4K library but have pulled a sample of about 10 different movies, some true 4K and some remastered, and have not encountered this.  Does anyone have any thoughts on what the problem could be?


Hi @LTRUMAN, do you have the latest firmware 1015 for the UBD-K8500  https://www.samsung.com/uk/support/model/UBD-K8500/XU/ ?  Possible fix otherwise is to reset the player by selecting stop button on top of panel for more tham 5 seconds with no disc inside.

 

However other customers have experienced similar issues.   if not resolved when after completing  these  tasks (or if already attempted) could   be a fault with the player, there is a seperate disc reader for 4k discs.

 

See this thread for some more information  https://eu.community.samsung.com/t5/TV-Audio-Video/UBD-K8500-problems/td-p/380943

4 REPLIES
Superuser I
Superuser I

@LTRUMAN wrote:

I am hoping someone can help me here.  I have the Samsung UVD-K8500 and have just started encountering problems with playing some 4K moview.  I purchased Thor Ragnarock and Avengers: Infinity War 4K versions.  I attempted to play the 4K version of these movies and they will not play.  The player recognizes the disc and tries to load it but it gets stuck at the loading prompt. The screen goes black and the upper right corner the loading icon is spinning.   The player locks up and none of the functions work after the movie starts to load. I have to turn off the player to get it to eject, and it takes a long time (3-4 minutes and longer) to get the player to power off.  I have put in other 4K movies and they play fine, the blue ray play fine.  it appears to be something with these specific Marvel movies that I can tell.  I have not gone through my entier 4K library but have pulled a sample of about 10 different movies, some true 4K and some remastered, and have not encountered this.  Does anyone have any thoughts on what the problem could be?


Hi @LTRUMAN, do you have the latest firmware 1015 for the UBD-K8500  https://www.samsung.com/uk/support/model/UBD-K8500/XU/ ?  Possible fix otherwise is to reset the player by selecting stop button on top of panel for more tham 5 seconds with no disc inside.

 

However other customers have experienced similar issues.   if not resolved when after completing  these  tasks (or if already attempted) could   be a fault with the player, there is a seperate disc reader for 4k discs.

 

See this thread for some more information  https://eu.community.samsung.com/t5/TV-Audio-Video/UBD-K8500-problems/td-p/380943

Apprentice

Hi @JAMES4578

 

 I did not have the latest firm wear.  I had looke for a software update but only in the settings.  I did the update and now my player is working!!  Thanks so much for the information!  

Highlighted
Superuser I
Superuser I

@LTRUMAN wrote:

Hi @JAMES4578

 

 I did not have the latest firm wear.  I had looke for a software update but only in the settings.  I did the update and now my player is working!!  Thanks so much for the information!  


Hi @LTRUMAN, no prob-glad the issue seems resolved.

Apprentice
@james4578, for now at least. I set it to auto update, hopefully it won't happen again. I was not looking forward to having to get another player.
Top Liked Authors