Support

Open search

UHD not activating UE55HU8580QXZG

Highlighted
SOLVED
Apprentice

Hi there, 

 

I just got a UHD box from my TV provider and it does not work. The message says that the TV does not support the required UHD protection.

 

I am using the cables that the TV provider gave so it is not the cables. I have also activated HDMI UHD colour(with cable unplugged). Anyone have any idea why this is still not working?

 

Software version is 1400 (no updates available,so assume that this is most recent for my tv)

 

Thanks, 

 

Neil

1 ACCEPTED SOLUTION

Accepted Solutions
Superuser I
Superuser I

@Neilius wrote:

Hi there, 

 

I just got a UHD box from my TV provider and it does not work. The message says that the TV does not support the required UHD protection.

 

I am using the cables that the TV provider gave so it is not the cables. I have also activated HDMI UHD colour(with cable unplugged). Anyone have any idea why this is still not working?

 

Software version is 1400 (no updates available,so assume that this is most recent for my tv)

 

Thanks, 

 

Neil


Hi @Neilius, upon checking 1400 is the latest firmware on the Samsung site. However this is a 2014 model and only the MHL port can be used for UHD  output as the only one HDCP 2.2 compatible.  (the High Bandwidth Digital Copy protection)  It was only from around 2016 that all ports were suitable on UHD Tv's.   Therefore all you using the correct port and do you have UHD colour activated on this one.  Your specific model is not on this list but it was port 4 for the HU8500 and in any  case will be clearly labelled.   UHD Ports on TV's     I'm not sure on your provider ,are you based in Uk/Ireland and if so is it Sky/Virgin/BT. I would not rule  out it being your cable even If should be ok as provided with new Box.   Should be able to check guide online and if still issues may need to get back to them.  For instance on Sky there is an 8 bit and 10 bit setting or the Box can automaticaly find the best setting that works for your TV.

 

 

4 REPLIES
Superuser I
Superuser I

@Neilius wrote:

Hi there, 

 

I just got a UHD box from my TV provider and it does not work. The message says that the TV does not support the required UHD protection.

 

I am using the cables that the TV provider gave so it is not the cables. I have also activated HDMI UHD colour(with cable unplugged). Anyone have any idea why this is still not working?

 

Software version is 1400 (no updates available,so assume that this is most recent for my tv)

 

Thanks, 

 

Neil


Hi @Neilius, upon checking 1400 is the latest firmware on the Samsung site. However this is a 2014 model and only the MHL port can be used for UHD  output as the only one HDCP 2.2 compatible.  (the High Bandwidth Digital Copy protection)  It was only from around 2016 that all ports were suitable on UHD Tv's.   Therefore all you using the correct port and do you have UHD colour activated on this one.  Your specific model is not on this list but it was port 4 for the HU8500 and in any  case will be clearly labelled.   UHD Ports on TV's     I'm not sure on your provider ,are you based in Uk/Ireland and if so is it Sky/Virgin/BT. I would not rule  out it being your cable even If should be ok as provided with new Box.   Should be able to check guide online and if still issues may need to get back to them.  For instance on Sky there is an 8 bit and 10 bit setting or the Box can automaticaly find the best setting that works for your TV.

 

 

Apprentice

You are completely right. Thanks for your help!

Superuser I
Superuser I

Hi @Neilius, was changing the HDMI  port the solution or was anything to do with settings?  Just wish to check.

Apprentice

Sorry for the delayed response. It's port 4 nothing special needed.

 

Port 1-3 have the option to change the setting that's supposed to upgrade to hdmi 2. Port 4 not. I never tried this port as I assumed that this one was hdmi 1 only.

Top Liked Authors