Support

Open search

TV Plus

First Poster
If you turn off any net then you lose arc channel on your receiver which is highly undesirable
Just Browsing

This will be the last Samsung TV I ever buy, or any other Samsung product for that matter. Ridiculous they think they think they can force their adverts on paying customers. First it was the little banner advert on the home screen - okay that annoyed me but I guess I'll have to live with it. Now they're putting intrusive channels which you can't seem to get rid of and randomly keeps switching to it, even though I have no interest in ever using it.

Apprentice

I can confirm that this has been resolved to my satisfaction. It is a different method of deleting this app and a little more comicated but it has gone. 

 

I was sent a vide which gave me good directions which worked. 

 

I understand that Samsung may have inadvertently thought it was offering some bonus to our new TVs however  as with other widely used similar services, Samsung are yet again late to realise that customers prefer to choose thier content rather than have it forced upon them. Customers are already happy with similar services available that are more established. This is true of my phone and the Samsung cloud services and this TV. 

 

Thank you for resolving the issue. Please consider your new competitive  servives as an option in future. 

Apprentice

This TV plus thing was bugging me for the last few weeks, its not on what samsung has done, deleted the channels, seems fine now.

Explorer
@Daverandall
Could you please explain what you did to solve the Problem ?
Lot Of people are waiting for the Solution !
-I was sent a vide which gave me good directions which worked. -
Where Can We find it??
Apprentice

This is the only solution that worked. If you reset the TV "to factory" it takes you through a number the start up options/settings. In there you can chose your primary source (hdmi). In my case I beleive the pop up happened because I didn't have a constant primary source as I don't have a TV box so it would default to this. Now I have set Virgin media as my primary source through HDMI and although the Rakuten My tv source is still there it always starts on the Virgin media source. That said I don't actually have a Virgin box so there is never any display on this option but at least my TV doesn't start on My TV. I'm going LG Oled next. Samsung have become power hungry and are abusing customers with the mindset that "we own the product and you want it so deal with it". Imagine you bought a new car and adverts were forced on you over the radio. It's a violation!

Superuser I
Superuser I

There a few  solutions mentione in this thread which should  solve the problem, whether it's editing channels or factory reset/changing primary source. whether we like or not many companies will heavily promote services, in my view it's the quality of the TV which matters however customers are entitled to reach their own conclusions.

Apprentice

My TV has started switching to TVPlus every 10 MINS. Absolutely shocking! I use it a a monitor and have no intension of watching tvplus. Sometimes i watch netflix or youtube. Most of my time I am using this as a workstation for study. Please someone give a clear discription how to disable tvplu. Its killing me and I need to study. Samsung just massively went down in my opinion. I have just tried deleting the tv plus channels in the channel list. 

First Poster

This is how...

 

you cannot do do it with the smart remote you need the standard tv remote. 

Press ‘guide’ (or channels whatever it is in the middle of the remote) 

 

go go to top right corner and ‘edit’ channel list. ‘Delete all’ 

 

it it should not show up again

Apprentice

Its looking like it has worked. So happy. Thank you all

Top Liked Authors