Support

Open search

Samsung Smart TV stopped connecting to internet (wifi and Ethernet)

New Member

I have an older Smart TV.. same issue. Tried everything i'v seen. Still no luck. Keep posting if you find a solution.

First Poster

I was watching tv the other day and one of the kids unplugged the modem, when the modem swicted back on again the tv couldnt find the signal. This has probably happened to me half  a dozen times. The only solution that has worked for my is to unplug the tv and plug one of the modem cables into the back of the tv, then go to the internet setting and change to 'wired' then i watched netflix for a while then the wireless worked fine again.

I dont know much about this stuff but we dont have a fixed IP address, if IP address changes maybe the TV gets confused. Changing the dna settings didnt work for me. 

Surprising samsung doesnt come into this forum and solve the proble, 

 

Apprentice

Just wanted to say that my TV just started connecting tothe WIFI.  Didn't connect for 5 days.  Tried all the options offered on Samsung site and those of so many of those on this forum.  On the 6th day, I turned on the TV, and voila! it connected to WIFI.  While I enjoy my Samsung TV , I have 3 of them, I think troubleshooting should be more straightforward and user friendly.

 

Good luck to all of you. As I said in my previous post,  when my TV did not even see the wifi, Ifinallychanged the Network Interfce Card ( NIC)  and this worked beautifully and is as easyas changing batteries in the remote.  Of course there are alot more screws to remove and replace, but it is less expensive than paying for a repair.  Find instructions on YouTube. 

 

Note this issue was notthe same as the latest issue I had. Om the latest issue the TV found the WiFi but didn't connect for6 days. 


Apprentice

I've tried all of the things suggested here - thanks everyone.

 

I cannot get the TV to stay connected reliably except when I tether with my mobile phone. 

 

Does anyone know of the firmware version shown as 1530 is actually 1530.1 as available on the website? I've tried it just in case and it doesn't want to update.

 

Could this be ISP specific?  Im with SKY .

 

I have tried wired and wireless - no problem connecting to my network most of the time but cannot get outside most of the time. Netflix runs for a few seconds and Amazon only works occasionally. 

 

I have also tried resetting Personal Service ID in the terms and conditions menu.

 

Hope someone has more luck! 

 

Martin

Apprentice

Just had a 30 minute call with Samsung - they don't believe that they at fault as my TV works when tethered to my phone. This seems logical except that my other LG and Amazon devices can connect to Netflix and Amazon without a problem. I also have Cat5 cabling in my house between TV and router so I think I have all bases covered. 

 

Feels a bit like Samsung burying their heads in the sand.......

First Poster

well.. i have a VERY weird update on my issues.  Just a reminder my issue was that both my samsung and my tcl rokutv stopped being able to pass their internet test but the wifi test passed fine.  Much like the OP, i tried everything the forums suggested.

 

i am running on comcast business with a cisco 3941B gateway.  I also have a QNAP 1635 NAS.  

 

Very long story short(er), my Qnap was on local ip .6, both tv's are on dhcp and have ip .224 and .236.  The qnap provides samba shares and that is it.  I unplug the qnap from my network and both tv's pass 90% of their internet tests, the samsung does fail every now and then, 1 in 10 tests roughly.  Plug the qnap back into the network, they fail 100% of their tests... wierd, but not crazy weird.. here's where it just doesn't make ANY sense at all.   if i change the static ip of the qnap to say .2, both tv's test fine on the internet again, 90% pass rate.

 

The qnap doesn't provide ANY sort of routing, proxy or firewalling.  The default gateway on all devices is the comcast gateway at .254.

 

I'll have to wait until i can shut everything down again and put a packet sniffer on the network to see what the heck is going on!  this is some crazy stuff!

New Member

Hello. 

Usually when something gets kicked off the wireless it's because some other device in the house is using the same internal IP. 

So I went to the router settings to se if that's the case.

It wasn't.

 

My router has a 2.4 GHz and a 4GHz band and for some reason the TV always connected to the 2.4GHz one.

So I turned off the 2.4 GHz option from the router and I also set a manual IP form the TV. Something like 192.168.1.100. That way it wont interfere with other devices.

 

I'm not sure if the move to a 4Ghz or the manual IP did the trick but so far it work.

New Member

I recently moved to a house that only receives ATT Direct TV satellite, from a house that had ATT U-VERSE cable.

 

The Samsung TV hasha bandwidth meter indicating not enough bandwidth to watch shows on Amazon Prime TV, but I am able to watch programs that are not HDTV.  I did not have this problem with cable.

 

So, how do I get HDTV on my Samsung TV?  When the TV indicates there isn't enough bandwidth to watch HDTV.

Apprentice

@Mazaz wrote:

Hi there, 

I have the same problem (I have to do a network reset ... and re-enter password) every time). It's less annoying that way than resetting the whole TV. 

I'm currently in discussion with Samsung because its insanely annoying and the TV is not old at all. I'll let you know how I get on. 

 

This is really unacceptable, isn't it? 


Extremely unacceptable! I have the same issue with a TV that isn't even 3 months old. Did they ever get back to you? Please advise on the process you on followed and the outcome.

 

Regards

New Member

After 2 days of several support phone calls and Google, I successfully solved my new Samsung TV Internet connection problem:

1) Separated 2.4 and 5 GHz into two separate network names. It used to share the same network name. (I can see only the 2.4GHz network on my TV.)

2) On Samsung, entered Network DNS as 4.2.2.1

3) On Sumsung, in the Internet Network lists, chose "WPS"

4) Pressed and held the "WPS" button on my modem/router for a few seconds

 

 

 

 

 

Top Liked Authors