Support

Open search

Invalid mac address once tv is turned back on from being off

New Member

Hi hopefully someone can shed bit of light onto what's going on. So I noticed last week that my tv wasn't connected to the wifi so I tested the connection to which I receive a error saying that my mac address is invalid, so I did the obvious thing and reset my tv by pulling it from the mains and plugging it back. When I turned the tv back on it would reconnect, but then I started to notice that every time my tv is turned off for a short amount of time, I turn it back on and the wifi is disconnected again with the error invalid mac with 0,0,0,0 on every option. This happens every single time my tv is turned back on after being off and I have to go through it all again with unplugging from.the mains and turning back on this is the only way I can get it to connect to the wifi again, it only happens on the wifi as I've connected a Ethernet cable and tested it and it always has a solid constant connection with the cable. My router is about 2 feet away from my tv so that isn't a issue and every other device on my network runs perfectly so I know the network isn't a problem, I've tried all sorts of trouble shooting including factory resetting my tv and router, I've tried manually inputting the ip, dns ect.... I've tried getting the latest software from the samsung website and updating the tv. I've tried pretty much everything I can think of but nothing has helped. The tv was fine when I first bought it I've only noticed this recently the tv is about 5 months old. Anyone having the same issue or no a fix? I'm waiting on a technician to get back to me can't imagine them being much help. I. Just wondering if I should take it back to Argos or not as it's still under warranty. Any help is appreciated. The tv model is UE49MU6220. Thank you20180709_140402.jpg

 

14 REPLIES 14
New Member

I forgot to mention this is what it does until I reset by disconnecting from mains. The mac address will appear invalid then i'll go to reconnect to my wifi but it'll just forever search until it it eventually closes and takes me back to the option where I select wifi or wired. So I have to unplug fro. The mains then power the tv back up then it will find my network then I can connect again... obviously until I turn my tv off then I have to go through the whole ordeal againScreenshot_20180709-194118_Gallery.jpg

 

New Member

Exact same problem here. There are multiple thread over the internet about samsung tv losing the wifi connection but no real solution seams to emerge. My TV is a QE55Q7FN.

New Member

I have the same problem and looking for a solution. 

Observer

Same problem started this week with my UA55KU7350 and no solution till now. Hopefully it is not a problem with a system update 

First Poster

Same problem here with exact details you described, I contacted samsung service and someone came and hard-reset it, it worked just fine for about a day without any problem but the day after, it appeared again, too bad for a big company like Samsung that have this kind of problems with their Superior TV’s, I’ll contact them again and will come here with results

F60B06E3-341E-4550-9442-0FC114165808.jpegIt is in Persian language but the same error

 

First Poster

go to settings > software update > resset 

 

then unlug the TV from power wait for 2 mins

plug the TV back on power and set it up again

it will work till your wifi card in your TV heats up

 

its something samsungs manufacturing process, i think  they use some inferior quality componenets in their wifi nnetworking component which fails.

Superuser I
Superuser I

Customers affected should firstly ensure you have the latest firmware.   However if so and  rebooting router/resetting Network /unplugging  by themselves do not solve the issue,   here is a recommendation which as worked for some:

 

Power off TV   (plug out from the outlet )  for 30 seconds and  power on again

Now go to Menu->Support ->Self Diagnosis ->Reset

This will reset TV settings and will  therefore need to power on TV

 

As this is new settings and you need to set  your language and so on.If connected to Router but  not the Internet try the following:

 

Go to Network -> status -> IP settings and then  set DNS to 4.2.2.1

 

Subsequently you should be able to connect to Internet, note though that you will need to download apps again.

 

Further information on this solution plus further advice contained in this thread https://eu.community.samsung.com/t5/TV-Audio-Video/Invalid-Mac-address/m-p/163180#M1044

 

 

 

First Poster

hey dude  Thank you for your reply

 

i dont know about you i mean are you paid by samsung?

 

but this flipping samsung is a customer cheat company, i have 2 TVs with the same behavior

the thrird product was Evelution Kit 4500 got it in Jan 2019

it started showing the same bull in 2 months of usage

 

Thanks fully the retailer took it nback even though they had 30 days return policy

 

samsung support said they cannot provide support because the serial number is invalid!

but i let the agent to remote in to the device and see the issue himself

when in mac address list (bluetooth, lan & wifi ) there is no MAC address lsited for the wifi part of that device

then its nothing to do with m darn network.

 

you dont need to reset your network

if all of your devices are connected to your wifi network

then you dont have to reset your network

 

there is no firmware

and firmware cannot hard code a MAC address in a networing equipment!

 

there are thousands of people whith same issue all around the world

 

all you need to do is search google "Invalid mac address+samsung"

 

power off and reset ? what year are you talking about 2019 or 1980?

flip samsung they are flipping cheats

 

changing DNS wont make any diffrence!

if you happence to know what DNS actually does

its like you changing your post office because you are not getting your mail

when your flipping mail box dissapeared you cannot blame the mail man or the post office

First Poster

So here the results after nearly two week talking with two different persons in Samsung customer service about this problem: each of them told me two different solution which none of them worked!! (Reset Smarthub - Reset TV PowerOff and On) and as i said earlier on this thread, someone came and hard reset with their non smart controller which wasn't a permament solution, So finally they told me that they come and take the TV to check and test it in their service centre which is completely worthless as someone else that i know did it and took the TV as a reparied one but same day same problems,

My final advice is if you have a return garauntee get rid of this TV asap and get yo money and if don't just wait maybe a Software update gonna solve it. Definitely not gonna buy any Samsung product in future.

Top Liked Authors