Support

Open search

Invalid Mac address

SOLVED
Apprentice

Our TV (UE40J6300) has lost it's wireless connection to our home network. When trying to reconnect it I'm getting the following message: 

"Invalid MAC Address, call Samsung support" 

Have tried the TV reset function but no luck. All our other devices, phones, laptops etc connect without a problem. 

Our TV is only just over a year old. I have seen posts on other forums about this problem with Samsung TV's. 

Any help / suggestions on how this can be fixed without the need for calling out an engineer would be appreciated.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Apprentice

Hi AntsS

Well guess what, as I was looking for the software version I noticed that the Wireless Mac Address details were filled in again. So checked I could access the Internet and success. But for how long!!!!

Anyway the software version is T-HKMFDEUC-1480.4 and the Wireless Mac Address (while it lasts) is 78:bd:bc:5b:32:b7 

Look forward to your reply.

Observer

Tonight i called Samsung support and to my surprise the 'invalid MAC address' issue was addressed by the representative within a few minutes...

Steps:

Power off (plug out from the outlet ) the TV for 30s and plug in

Go to Menu->Support ->Self Diagnosis ->Reset

This will reset TV settings and will need to power on TV at this point

This is new settings and you need to go through setting your language etc. 

This will try to reconnect ... in my case it connected to my modem but not connected to internet

Go to Network -> status -> IP settings and set DNS to 4.2.2.1

Now you are all set and you should be able to connect to Internet

Remember, your apps would have been lost and so need to go to Apps and download your favorite ones again

 

I was amazed with the ease with with the representive handled the issue and she helped resolved this issue within few minutes.  This is the first time i approached Samsung and they set a great example of customer services ...

Kudos to them and i will recommend Samsung products to anyone, going forward.  Really impressed!

35 REPLIES 35
AntS Moderator
Moderator

Hi there, @ByronBear.

 

Is this guide any good for you? 


Prince_Community_Sig03.jpg

 Say "Hello!" to the Community in The Introduce Yourself Thread.

Apprentice

Hi AntS

Thanks for the link but the menu screens shown are different to what I get on our TV. However following the same basic procedure I can only get as far as trying to select a wireless network. It goes through the motions of searching for available networks, doesn't find/list any and goes back to the screen with the option to choose wired or wireless networks. After I put my original post up we found that the TV had regained the Mac address and was connecting to our network. This lasted until today when it's lost it again and the Invalid Mac address message is back. Looks like this could be an intermittent fault??? Once again we know the network is fine as all other devices connect to it without a problem. Any other suggestions??

AntS Moderator
Moderator

No worries. What's the software version you've got on it? Menu > Support > Contact Samsung.


Prince_Community_Sig03.jpg

 Say "Hello!" to the Community in The Introduce Yourself Thread.

Apprentice

Hi AntsS

Well guess what, as I was looking for the software version I noticed that the Wireless Mac Address details were filled in again. So checked I could access the Internet and success. But for how long!!!!

Anyway the software version is T-HKMFDEUC-1480.4 and the Wireless Mac Address (while it lasts) is 78:bd:bc:5b:32:b7 

Look forward to your reply.

AntS Moderator
Moderator

Thanks!  You're all up to date with the software there.

 

And spooky. Have you tried resetting the router to see if that gets you a more stable connection on the TV?

 

 


Prince_Community_Sig03.jpg

 Say "Hello!" to the Community in The Introduce Yourself Thread.

Apprentice

Ants. I have the same problem on my 8000 series 65 inch no valid Mac address for wireless networks. 

Version t-jzmakuc-1203.6,bt-s

First Poster

Sad to say, but I too have this issue all of a sudden tonight with my 65ks8500. The MAC shows just all zeroes and there's no connection possible.

 

For a few days I have had issues with my smart remote disconnecting, not responding (tried everything, change batteries, pairing etc, only thing that works until it finally pairs again, is the on-off button), and now this. 

AntS Moderator
Moderator

Hi @Binghamton and @svache.

 

Any joy with manually setting the DNS settings?

 

Manual_DNS.JPG


Prince_Community_Sig03.jpg

 Say "Hello!" to the Community in The Introduce Yourself Thread.

First Poster

Hey @AntS, 

 

I'm not sure exactly what happened, it's back normal again this morning.

I do find it odd though, all wifi settings including the MAC address were all zeroes, and while I can understand the other settings (such as DNS or IP) to change, the MAC shouldn't just change. 

 

Anyways, it's back to normal for now. Oddly enough, the smart remote is also back to normal at the same time, which makes me wonder if the two are related somehow (the remote refused to pair back to the tv last night).

 

Top Liked Authors