Wsparcie

Open search

ue557002t - nie działa smart view

Highlighted
First Poster

ue557002t - nie działa smart view

Witam,

Po zainstalowaniu aplikacji Smart View na PC nie mogę się połączyć z telewizorem (urządzenie jest widziane). Występuje komunikat 'Something went wrong. Please try again'. Co może być przyczyną?

8 ODPOWIEDZI
Expert

Dot.: ue557002t - nie działa smart view

Hej @mmmach7

 

Spróbuj wykonać reset odbiornika w Menu>Pomoc Techniczna>Diagnostyka>Resetuj standardowy kod Pin to 0000, jeśli to nie będzie pomocne to wtedy polecam sprawdzić na innej sieci lub wyłączyć blokady w routerze gdyż mogą one być przyczyną braku komunikacji.


Jeśli moja odpowiedź była pomocna, zaakceptuj ją jako rozwiązanie albo kliknij kudo!
First Poster

Dot.: ue557002t - nie działa smart view

Niestety reset nie pomógł. Nie sądzę, by był to problem routera, smart view działa poprawnie z poziomu aplikacji na telefonie. Oprócz tego utworzyłem sieć WiFi na telefonie i próbowałem na niej spiąć komputer z telewizorem poprzez smart view, bezskutecznie. Aplikację testowałem też na dwóch różnych komputerach.
Navigator

Dot.: ue557002t - nie działa smart view

hej @mmmach7

W takim wypadku warto zobaczyć czy programy zabezpieczające komputer, tzn. firewall lub antywirus, nie blokują działania aplikacji.

New Member

Dot.: ue557002t - nie działa smart view

Bardzo proszę o pilną pomoc w rozwiązaniu tego błędu.

Smart view znajduje mój TV, ale po kliknięciu wyskakuje komunikac "somthing went wrong. Try again".

 

Widzę po forach, że ten problem występuje powszechnie.

 

bh

First Poster

Dot.: ue557002t - nie działa smart view

Witam,

mam dokładnie ten sam problem z nowiutkim UE50MU6102

 

Wydaje mi się, że to jest problem z aplikacją Samsung Smart View (v 1.6.0.5), ponieważ w tej samej sieci lokalnej telefon z androidem i applikacją Samsung Smart View działa prawidłowo, dowolnie mogę przeglądać multimedia telefonu na tym telewizorze.

 

Wracając do PC, firewall na windowsie 10 został wyłączony całkowicie i problem nadal występuje.

Włączyłem logowanie zdarzeń do pliku dla Samsung Smart View, mam nadzieję, że to pomoże.

192.168.1.100 - lan gateway.

192.198.1.101 - pc z zainstalowanym smart view.

 

Dajcie znać czy potrzeba czegoś więcej, ponieważ komunikat "something went wrong" przy logowaniu na poziomie DEBUG nie jest zbyt wylewny.

 

2017-09-17 13:21:28,441 [1] DEBUG SmartView2.Log4NetLogger 1.6.0.5 [SmartView2][DevicePairing]StartPairingAsync started...
2017-09-17 13:21:28,452 [16] DEBUG SmartView2.Log4NetLogger 1.6.0.5 GET /ws/apps/CloudPINPage HTTP/1.1
HOST: 192.168.1.101:8080
CONNECTION: Keep-Alive
USER-AGENT: httpclient v0.1


2017-09-17 13:21:28,489 [1] DEBUG SmartView2.Log4NetLogger 1.6.0.5 [SmartView2][DeviceListViewModel]something went wrong.
2017-09-17 13:21:29,326 [5] DEBUG SmartView2.Log4NetLogger 1.6.0.5 [UPnP][UPnPDeviceDiscovery]deviceListener_AnswerReceived started...
2017-09-17 13:21:29,333 [5] DEBUG SmartView2.Log4NetLogger 1.6.0.5 [UPnP][UPnPDeviceDiscovery]deviceListener_AnswerReceived Update Device.
2017-09-17 13:21:29,339 [5] DEBUG SmartView2.Log4NetLogger 1.6.0.5 Message is HTTP/1.1 200 OK
CACHE-CONTROL: max-age=600
DATE: Sun, 17 Sep 2017 12:21:21 GMT
EXT:
LOCATION: http://192.168.1.100:1980/InternetGatewayDevice.xml
SERVER: POSIX UPnP/1.0 UPnP Stack/1.11.0.0
ST: upnp:rootdevice
USN: uuid:057089d8-6332-1f89-4ea4-64084a2dbf26::upnp:rootdevice

 
Pliki logów i xml udostępnione w OneDrive:
 
 
Pozdrawiam
Marek
First Poster

Dot.: ue557002t - nie działa smart view

Dobra, szybko grzebnąłem i aplikacja Samsung Smart View nie potrafi wystawić zasobu /ws/apps/CloudPINPage, który pewnie jest niezbędny do kontynuowania parowania:
curl -X GET http://192.168.1.101:8080/ws/apps/CloudPINPage -v
Note: Unnecessary use of -X or --request, GET is already inferred.
* Trying 192.168.1.101...
* TCP_NODELAY set
* Connected to 192.168.1.101 (192.168.1.101) port 8080 (#0)
> GET /ws/apps/CloudPINPage HTTP/1.1
> Host: 192.168.1.101:8080
> User-Agent: curl/7.55.1
> Accept: */*
>
< HTTP/1.1 404 Not Found
< Access-Control-Allow-Origin: *
< Access-Control-Allow-Headers: Content-Type
< API-Version: v1.00
< Content-Length: 0
< Date: Sun, 17 Sep 2017 12:04:54 GMT
< Server: WebServer
<
* Connection #0 to host 192.168.1.101 left intact
First Poster

Dot.: ue557002t - nie działa smart view

Pomyłka z adresami Emotikon: Mrugający
192.168.1.101 - telewizor
192.168.1.104 - pc
192.168.1.100 - router

Czyli wygląda na to, że TV nie wystawia wymaganych zasobów. Jeszcze pokombinuję. Mam teorię, ale muszę ją sprawdzić.
First Poster

Dot.: ue557002t - nie działa smart view

Niestety nie wiem jak to ugryźć. Skoro dla /ws/apps... dostaje zawsze 404.

Według dokumentacji http://developer.samsung.com/tv/develop/legacy-platform-library/art00030/index

TV odrzuca moje próby, jako że komunikat wyskakuje natychmiast nie wydaje mi się aby był to timeout a na tv nie wystakuje żaden komunikat pytający o akceptację parowania, nawet po resecie całego urządzenia.

 

The authentication the response messages from the TV to the mobile device are as follows:

  1. When the user selects Allow , the TV sends an Authentication Success response message to the mobile device. After that, the mobile device can connect to the TV.

    HTTP Response Message = OK (200)

  2. When the user selects Deny , TV sends an Authentication Failure response message to mobile device. After that, the mobile device displays a Authentication Failure message and disconnects with the TV the mobile device no longer displays Denied TV in the TV list.

    HTTP Response Message = UNAUTHORIZED (401) or NOTFOUND(404)

  3. When the user tries to connect 5 devices with the TV simultaneously, the TV sends a HTTP response message for full connection to mobile device. After that, the mobile device can display a Full connection message and disconnect from the TV.

    HTTP Response Message = SERVICEUNAVAILABLE (503)

  4. When the user does not select allow or deny, the TV closes the popup message and sends a “Authentication Timeout” response message to mobile device. After that, mobile device displays a Authentication Timeout message.

    HTTP Response Message = UNAUTHORIZED (401) or NOTFOUND(404)

  5. When the user enters the Network Menu (Menu -> Network -> AllShare Settings) and deletes or denies the mobile device, TV sends a HTTP response message for deletion or denial to the mobile device.

    HTTP Response Message = UNAUTHORIZED(401) or NOTFOUND(404)

Nie mam pojęcia co jest można sprawdzić. Macie może jakieś narzędzie do diagnostyki parowania?

 

Pozdrawiam

marek

Autorzy z największą liczbą like