Support

Open search

Samsung galaxy watch and whatsapp calls

Apprentice

Hey Just make sure you have the problem, keep in mind three things  1. check it is blocked or hidden from app-> settings-> notification. 2. You should also allow notification from iphone's settings. Click on Settings> Notifications> What'sApp / SMS / Any other App> Toggle Allow (also click on lock screen, notification center & banner). 3. iPhone's Bluetooth settings. You will find 2 names in the settings for your watch. Connect both of them to call from watch. You want to get a pair request (with a code) in your watch. Tap on right to accept it. 4. If you can not find the 2nd name on the "My Devices" you need to forget the watch from My devices. Then on the other devices segment, you will find two names for your watch, connect them and then you will be able to call. Again, you just do not forget to ask the pair to connect the watch to your iPhone bluetooth settings. 

First Poster

@iOSTriXFixX wrote:

Hey Just make sure you have the problem, keep in mind three things  1. check it is blocked or hidden from app-> settings-> notification. 2. You should also allow notification from iphone's settings. Click on Settings> Notifications> What'sApp / SMS / Any other App> Toggle Allow (also click on lock screen, notification center & banner). 3. iPhone's Bluetooth settings. You will find 2 names in the settings for your watch. Connect both of them to call from watch. You want to get a pair request (with a code) in your watch. Tap on right to accept it. 4. If you can not find the 2nd name on the "My Devices" you need to forget the watch from My devices. Then on the other devices segment, you will find two names for your watch, connect them and then you will be able to call. Again, you just do not forget to ask the pair to connect the watch to your iPhone bluetooth settings. 


So it appears too work when paired to an iPhone but not a Samsung phone. How sad is that. 

Apprentice

Hello @Intelrhino 

Yes, but you just have to do it once. And also, not all the options will work or needed for you. 

These are some troubleshooting ideas

Hope your problem solves

cheers!!

 

 

New Member

I tried all these options still I don't receive any notifications  for WhatsApp calls on S3 frontier.

Explorer

Yes I have the same issue. Don't know if it's a Samsung app issue or the way WhatsApp displays these notifications. 

 

To summarise I get notified of WhatsApp messages on my galaxy watch but not WhatsApp calls. If anyone finds a fix please let me know and I will do the same. 

Apprentice

I have the same problem. I had Gear Fit 2 earlier and now I am using Galaxy Watch. I remember till around mid-2018 I used to receive WhatsApp call notifications with the ability to either pick up or reject it, on my Gear Fit 2 even though it doesn't have a mic or a speaker. But then it stopped and now I only receive a notification on my Galaxy Watch about missed WhatsApp call. This is terribly sad, we need a fix for this soon. I tried a lot of different combinations of settings, but nothing works. Hope Samsung and WhatsApp are working on fixing this problem.

New Member

I'm wondering if anyone from Samsung is watching this forum?

It's not only whatsapp but all other messengers calls like viber, skype etc that are not working. It's very sad. GW is the best smartwatch currently on the market but this SW bug makes me to return the watch back. I can't rely on my watch and keep my phone silent.

Top Liked Authors