Support

Open search

S8 smart view not working

Explorer
I'm really pleased.

These tv and phones cost a fortune and once we buy them we're stuck with them so when they have issues from day one it's major hassle and we wonder why we're working 2 jobs to pay for stuff that doesn't work lol

Did you get the Bluetooth working?
First Poster
Hello. I was not having issue with Bluetooth. My issue was regarding Smart View connection to listed TV after Android update.
Highlighted
Explorer

Ahh I see.

 

So you're Bluetooth works perfectly?

If so maybe you can help me. How do you get it to connect please as my will not.

New Member

It's a simple fix. I had the same problem.  Just remove the device from your TVs connected device list.. Then reconnect it.

Explorer

If you read through the above you'll see that doesn't always work and the same issues keep reoccurring.  The issue with these tvs seem to be update related and samsung doesn't seem to care as it's moved on to  newer models.  As they were recently dined 5 million  for intentionally making their own devices run slower to force new purchases I can only assume that's what's happening here.

First Poster

Hello

I have a J7 Sky Pro and my smart view stopped working too. I don't have internet or WiFi, don't have firestick or Chromecast, just my phone and Samsung TV. Tried the developer part where you allow permissions on phone, did the remove devices under tv settings. What did fix my problem was so simple. Turn of TV, unplug TV, wait 1 minute. Plug TV back in and tada, turn on smart view, wait, pick your TV and watch your phone on your TV. Also, Don't Mess With Texas. VatoLoco's 4ever, MAGA 2020!

New Member

I found on my samsung series 6 with note 9, i have to goto network status (on tv) and disconnect the tv from the home wifi.  Then screen mirroring connects fine from phone.   it appears the phone is trying to establish a direct peer to peer wifi connection, rather than going through the existing home wifi.   

 

 

New Member

I have been having the same problem, I would try to connect my Galaxy S8 to my Samsung Smart TV by swiping down from the top of the screen and using the smart view symbol , but it would never connect.  This is how I finally got the screen mirroring to work - I removed my phone from the 

device  list by going to the TV menu, network, screen mirroring, device manager.  I then deleted my phone from the device list.  I also made sure my TV didn't need an update.  I then removed my Smart View app and re-installed it.  Once I opened the Smart View app again it found my Samsung TV.  I put my TV on screen mirroring,  then swiped down from the top of my Galaxy S8 and pressed the Smart View symbol.   You need to always make sure your TV is connected in the Smart View app before trying to connect to the TV using the smart view symbol.   I hope this helps.

New Member

This worked just fine for me too! you can find the update option on SUPPORT, at the bottom of the menu.

First Poster
Try this. On you s8 go to apps/google play services and in the permissions make sure you allow the microphone permission.
Top Liked Authors