Support

Open search

S8 Smart Lock issue (After Oreo update)

SOLVED
Apprentice

I know others are posting about this, but rather than tack on to someone else's thread I wanted to share my experience with Smart Lock.

 

Basically, since the Oreo update, Smart Lock is temperamental and only works sometimes, with no real indication as to why/why not. I am only using Trusted Locations and prior to the update, this feature worked like a dream and was a real selling point of Android (for someone like me who is a recent convert from Apple). 

 

Here are the things I have tried:

- Deleting all the stored locations and then enabling them from scratch. 

- Removing the Trust Agent, rebooting and enabling the Trust Agent again

- Clearing credentials 

- Factory reset

- Resetting all biometrics 

- Clearing device memory and storage in Device Optimisation

 

None of these things (which were various 'fixes' cited on other forums has done the trick. Smart Lock will work for a while and then it will stop working. And I don't just mean the '4 hours of inactivity' thing where a password/biometrics is required, it can work for, like, 20 minutes and then, suddenly, in the very same location, it can require biometrics/PIN again!

 

Most frustrating, and I really hope Samsung are working on a fix, or it'll be off to buy a Google Pixel for me.. 

Screenshot_20180419-125734_Brave.jpgSmart Lock is enabled but, surprise, surprise, the phone wants biometrics or PIN...

 

1 ACCEPTED SOLUTION

Accepted Solutions
Apprentice

Weird solution (courtesy of someone on a Google Pixel forum - err, thanks, Samsung....) but working so far:

 

I uninstalled all updates to the Google app, turned off automatic updates in the store, removed all my SmartLock settings including my Screen lock settings and restarted the phone.

 
After the above, I added my fingerprint and PIN and set up SmartLock once again. It's working now with no issue since this afternoon. 
 
Seems like the Google app itself is the culprit, so all the people posting 'fixes' to do with the Maps app seem to have been pointing fingers at the wrong Google software!
 
If you have tried everything else, try the above and see if that works for you, too.
5 REPLIES
First Poster

I have tried the same. It works sometimes. And as usual the updates takes so long before Samsung releases a new one. Next phone won't be a Samsung. Only chance to have a working Samsung phone is to ignore the version updates... It ruins them every time... 

Apprentice

Weird solution (courtesy of someone on a Google Pixel forum - err, thanks, Samsung....) but working so far:

 

I uninstalled all updates to the Google app, turned off automatic updates in the store, removed all my SmartLock settings including my Screen lock settings and restarted the phone.

 
After the above, I added my fingerprint and PIN and set up SmartLock once again. It's working now with no issue since this afternoon. 
 
Seems like the Google app itself is the culprit, so all the people posting 'fixes' to do with the Maps app seem to have been pointing fingers at the wrong Google software!
 
If you have tried everything else, try the above and see if that works for you, too.
First Poster

It works! Thank you!

Shame for Samsung...

Apprentice

My older Samsung J5 still doesn't understand the phone being in smart lock area after 4 hours.  Earlier I had to resort to Restarting the phone every 4 hours  to make the phone understand that it is still in safe area. Yesterday I did find a solution that doesn't require restarting the phone =):

1) Once the phone starts to ask for Pin again, log in with a pin code

2) Open the list of currently active applications and Close the Google Maps if is active by dragging it away from the screen. 

3) Open the top menu and Turn off the Location needle icon. 

4) Open the Google Maps and wait until it asks to use Location and Allow Maps to use it, wait until you see the little Pin icon on the top of the screen and see that phone has find your location correctly. 

5) Leave the Google Maps active on the screen and close the lid or turn off your screen. When you open the lid or screen a bit later you should find it working for the next 4 hours!

Enjoy!!!

New Member

Just tried that and didn't work. Still asking for my pin code. Seriously annoying feature.

Top Liked Authors