Support

Open search

My samsung J3 2017 keeps restarting

Explorer

 i can't belive doesn't work.. for me work perfectly, no reboot from yesterday.. "game optimising" must dissapear from applications list after you desinstall the updates..

Explorer

@BM16 wrote:

" in the applications go to 'game optimizing service', make a forced shutdown and uninstall updates of the application. "

Doesn't work, phone still reboots while gaming.


Not suprised this doesn't work. I'm not going to even try what they've said. We should all wait for samsung to fix this. Remember, this has happened on other devices in the past and it has no proven fix on any device. Android 8.1 is most likely going to fix our issue the way it was built to in the past. I'm suprised Samsung didn't just give us 8.1 in the first place - its main purpose was the resolution of this issue.

Explorer

you can wait without playn' games or you can wait still  playn' games.. your choice!

Apprentice

Guys, can you take few minutes to explain me more clearly what this fellow said, how to fix this issue. Do I need to go in settings, then in applications, but I can't find 'game optimizing service'. So, please can somebody help me. Before few days I bought this phone, and everytime when I go to work I'm playing Pokemon Go and it crashes my phone. I need to solve that, because I saw that this is happening in other apps... It's a shame that Samsung update and destroy everything. My Samsung core prime old phone was better then new one... Can't believe, if this don't work and Samsung don't fix that issue, I'll never support this company anymore.

 

ps. My good friend works on very popular radio station, so I can spread that. It's a shame...

Apprentice

OK, here's my attempt to explain what you have to do - though it is no different from what has already been said.

Go to Settings.

Scroll down to Apps and select it

Scroll down the list to find "Game Optimizing Service". 

Hit FORCE STOP., and then hit FORCE STOP in the popup that appears.

Then find the three dots and top right, click on it, and select "Uninstall Updates".  You will be asked whether you want to replace Game Optimizing Service with the Factory Version.  Click OK.

Go back to Settings/Apps and check that Game Optimizing Service no longer appears in the alphabetical list of Apps.

I can't tell you whether your games will now work without crashes, but mine all do.

BUT...  there is one snag.  My experience is that the system will periodically silently reinstall the updates to Game Optimizing Service.  So, before starting to play a game, always go into Settings/Apps and check that it hasn't sneaked back onto your phone.  If it has, repeat the above.

It's obvious to me what is most likely to have happened... in the latest update to Game Optimizing Service, Samsung have done something that isn't compatible with the J3 2017, and they need to patch it, or remove that functionality (who needs it anyway?) until they can devise a bug-free version.  But this workaround clearly solves the problem for most people.

Apprentice

 Yes, I understand you... But, now I realize that there's another problem. That's why I couldn't find 'game optimizing service', because I don't even have that. I scroll down and only I can see is list of apps, at the bottom is "looking for something else? Storage, battery, clock style". You know, like in every section of settings. That means they maybe update something, but still don't work. Because my phone is new. Can't believe, now I can't even try to fix this.

 

But thank you my friend for your time. Just one more thing, can you take a screenshot where you see "game optimizing service" and post here, to be sure. Because, I don't underestand why others have that option and I don't, thanks.

Apprentice

Screenshot_20181130-190002_Settings.jpgOK, this is what it looks like on my phone, in Settings/Apps.  "Game optimizing service" doesn't appear, because I've banished it and it hasn't crawled back in again yet.  But previously it was directly undr "Game Launcher", where you'd expect to find it.  Is it possible that you've got a setting that hides system apps, or Samsung default apps, or something?  that's what I'd try.

Apprentice

I have started using the advise in referance to the Game Optimisation Service. I have noticed this is having positive affects, however, I found that it did as stated before reactivate itself and install the update again. To stop this you need to follow the above advise then once you have force stopped and uninstalled the update, go to Galaxy Apps and go to the three dots and select settings when you see update when: select turn off from the drop down this will prevent it from automatically updating and reactivating. 

Apprentice

I have found a fix you can guys all you have to do is download parallelll space lite add your game to the parallel space and play it/them through there 😁😁

Apprentice

You can fix the reboot when playing games by downloading game guardian once you have run through all the steps click 'non-root' then it will ask you to download an app and it will take you to a website where you will find an app (by scrolling down) until you find paralell space lite download it from the website (not from playstore) and install it then just add the game you want to play by clicking the 'add app' button and wa la no more restarting in games.

I think it stops because you are running the game through parralell space and not from the normal launch itself.

Top Liked Authors