Support

Open search

Galaxy Watch - screen wake up/turn off behaviour is irritating

Explorer

I got my Galaxy Watch on Friday and for the most part I love it. However, a couple of things really bug me about a) the consistency of the wake up gesture and b) its tendency to turn the screen off much more quickly than it should.

 

So for a) - sometimes I just find that the wake up gesture doesn't work at all and I have to put my arm down and then back up again until it works. This feature is one of the most fundamental aspects of a smart watch that needs to work. It is especially noticable if I'm lying down but occasionally causes issues when sitting or standing. I think it's something your engineers really need to look at as, after a quick Google, I've seen many people complain about it on the Gear S3. I hope this is looked into as the fact it was an issue back then but still hasn't been fixed is a bit of a bad sign to me...

 

For b) I have 2 main issues. 1 is that the screen timeout setting only applies if the watch was woken up by the buttons and not by the wake up gesture. I think it's fine to have a different screen timeout if it was woken by gesture, but it should really be a configurable option.

 

The other annoyance is that the screen turns off when you tilt the watch back down. I think this is OK if you've woken the watch up with a gesture but it should be possible to disable this if the watch has been woken up by buttons or the dial. 

30 REPLIES
AndrewL Moderator
Moderator
Hi @ConcreteLlama

Sorry to hear that these issues are affecting your enjoyment of your new Galaxy Watch. I'll feed this back to our R&D Team however all I can suggest in the meantime is to increase the screen timeout time via Settings > Display > Screen Timeout. If the screen fails to switch on as part of the wake up gesture feature then you can rotate the bezel or press the Home or Back keys to activate the screen and avoid having to lower your arm and raise it again. I understand that this isn't ideal and apologise for any inconvenience this may be causing you.
Navigator

Have to agree with that it doesn't stay on long enough. Very very annoying. 

As far as the wake up goes. I kind of get why you have to put your arm down in order to detect is rising again. It would be coming on and off when eating every mouthful otherwise.

Options to configure though would please everyone I would imagine. 

Explorer

My complaint about bringing my arm down then back up again was more the annoyance that it's frustrating to have to do when it should have worked first time - I totally get why you'd have to bring it down then back up again (or just rotate the bezel or press a button) if the screen times out. But yeah more options is always good - especially in the advanced section. If it's hidden away in an advanced setting it won't be a usability issue for new users so there's little harm in adding options.

New Member

"Watch Face Always On" simple does not work. If you activate that feature the watch face should ALWAYS be on, correct? Otherwise, rename it.

 

It is very random. Wake-up gesture has to be turned off, but even then sometimes the face times out. I want it on ALL the time. I don't care about battery life-- that's my issue to manage.

 

I have the same problem with my Frontier and current Galaxy. Maddening. This should be s VERY simple, basic function.

 

(Right now I have the gesture turned off-- otherwise the screen goes black immediately. Screen timer is set to 5 minutes-- the maximum. Screen goes black after 2 minutes. And with gesture off, turning the bezel won't even work-- I have to press a button to get the screen to turn on!)

Navigator

I didn't have an issue with it when I tested it. It dims a little when not raised but it is always on when the functionality is turned on.

Explorer

So I bought the Galaxy Watch today and this has been driving me mad  Whenever I wake the watch up through moving my wrist it times out after about 5 seconds and the screen goes blank. Naturally  I changed the timeout setting but it makes no difference. I came here to look for answers and it seems as per the original post, this setting only takes affect when you press the buttons to wake up? Seriously?! That seems insane. Why would it work differently? Surely this must be a bug! 

New Member

Hi, i have the same issue.

 

I would like to disable the need to wake up my watch, just keep it on 100% of time and when i want to turn it off i would like to do it manually.

 

Cheers.

New Member

I would also really like an "always on" or dont fall asleep  option - It's up to me if I need to charge it more often.

  

I also want to use my watch for running but the wake up gesture is very hard to do properly during a running workout just to check some stats - impossible when swimming...  An always awake feature particularly during a workout would be an excellent option.

New Member

At me was the issue that the good night mode was on. 

Top Liked Authors