Open search

Smart home App - not working

@ AntS thanks a lot for your prompt response including additional information :-)! Is there a place where we can follow the roadmap / scheduled improvements?  Maybe a developer community?  

AntS Moderator

@cool_vibe_tesla: No current plans on releasing a roadmap or a place to follow the doings of the various software teams, I’m afraid.


There is a developer’s site and Community, but it’s more aimed at non-Samsung techy folks out there wanting to develop apps for various Samsung products. Links if you (or anyone else) want to check them out: and


 Say "Hello!" to the Community in The Introduce Yourself Thread.




Kudo’s for getting the server bug fixed.

Would this also be the right place to suggest/ask for iPhone X screen optimization?

Smart Home app for iOS . . . well, just sucks. . . just finding it in the app store is a real chore. . . NO real links on Samsung to download iOS version on site? No secondary download sites. . . I am getting the very same problems that other are having. . . you sign in and it never connects to server!!! Never Has. Guys just make thing a little easy er. . . fix all the above problems. . . and update that ***** so it works with the latest iOS version!
Hi @AntS, some news about fix. For example, in my case, we have a different devices and not working at all. iOS version 8.4.1 in my old iPad2 and 11.2.2 in my iPhone 5s and another iPhone 7 Plus.

Some news?, test with Android, and not working!!!


Smart Home Service are ok? or not?


I have been experiencing the same issues as others  since upgrading to an iphone 8 ios version 11.2.5

App no longer connects to my induction range. Worked before. Get failed connection messages after going through the "AP /Smart Control" connection process. Re-intalling app makes no difference

First Poster

We also bought the ac due to smart home app. It doesn't work on different devices iPhone 5s, IPhone 6S , and IPad all fully up to date both with Samsung app and iOS versions 

First Poster
Are u still able to Use the app?

No I am unable to get past the final step where it connects to the server. It just fails at that point after a couple minutes of trying to connect.   The app worked prior to my latest iphone 8 updateSamsung app 1.jpgSamsung app 2.jpg

Top Liked Authors