Support

Open search

WiFi issue after s7 oreo update

Explorer

I updated the system update 3 days ago and since then I have had issues staying connected to WiFi. I'm constantly getting an exclamation mark next to the WiFi icon and it dips or lags every few minutes  The same happened to my partner's s7 when he updated the day after. Did a quick Google search and this has been a common theme for months. Anyone else having this problem? 

68 REPLIES 68
Superuser I
Superuser I

Hi @Rebkayskye

 

I updated to Oreo 8.0 a few months ago and Wi-Fi connection has been fine on my Samsung Galaxy s8 phone. 

 

May I ask if you've tried forgetting the Network Settings in the phone and reset it back up. 

 

That or clear the System File Cache which is performed by turning the phone Off and then from a set series of button presses will take you into the System File Cache.

 

A last resort could be to create a back up and Factory Reset. 

 

A Samsung Service Centre or Samsung Experience Store would be able to run a diagnostic on it too. 

 

 

Current Phone ~

Samsung Note 10+ 5G _256Gb > Model: SM-N976B._ Samsung One Ui / Pie.

Samsung Gear s3 Frontier Watch
Samsung Galaxy Tab A {2016}SM-T580

Explorer

Hi thanks for replying. I've tried forgetting the network but not tried the other methods yet. I just find it a coincidence that both my partner and I have the same problem after the same update. It's just very annoying because I'm having to keep using my data to do simple things on my phone. 

First Poster

I am having the same behaviour (the WiFi lags and sometimes the icon gets the exclamation mark) since I got the update to Android 8.0 on my S7 Edge a few days ago. It is some kind of incompatibility between the update and my dual band router Asus...

I did a factory reset when my S7 got the update.

The smartphone works great with Oreo except this really annoying issue.

 

Explorer

Without sounding rude I am actually pleased that it's not just me. I have done a search and apparently it's been happening for a while. I really don't want to have to get a new phone :(

Highlighted
Superuser II
Superuser II

That feeling when Im on 8.0 with Galaxy S9+ and you are on 9.0 ! with S7 only :manlol:

Explorer

Lol it is 8.0 but I keep pressing the 9 because I have fat fingers 

 

First Poster

I am also having the same issue, I got the update in Tuesday and nothing but wi-fi issues. Just keeps poping up with the Wi-Fi logo and Exclimation Mark.

 

I have tried everything

Forget Network

Restet Network Settings

Clear Cache

2.4Ghz and 5Ghz

Factory Reset

 

My internet is perfectly stable, I am talking to people, download and gaming online with no issue.

First Poster

Yes, it seems the new Oreo update also rolled out in The Netherlands today. I have updated my phone and now it will not connect to my WiFi at all. It just tries to connect for 10 seconds, stops for another 10, then goes back to trying.

I've tried to start it up in safe mode, but that didn't work. I've wiped the cache but to no avail. (BTW, it also showed a 'E: failed to clear BCB message: failed to find /misc partition' but I don't know if this is relevant.)

The only option now is to reset it back to factory settings? But how will that prevent the problem when my phone just starts updating again?

Apprentice

I am also having this same issue with Wifi after the update to Oreo. Tried clearing the cache and forgetting the network and still the same. Did you manage to find a fix? 

 

 

Top Liked Authors