Support

Open search

WhatsApp incoming call - screens remains off on S8

SOLVED
Apprentice

When my phone is locked and screen is off and I receive a call on WhatsApp, a notification about the incoming call displays briefly, but the screen remains off. How can I make WhatsApp turn on the screen to show the incoming call screen ?

Phone: Samsung Galaxy S8 - Model SM-G950F
Android: 7.0
Samsung Experience version 8.1
WhatsApp Version 2.17.146

Always On Display is enabled. Disabling it makes no difference.
I have tested the behaviour with Skype, Facebook - these apps do turn screen on for incoming call.

Checked on S8 of a colleague who experiences the same behaviour.

Reset WhatsApp notification settings: no luck

Re-installed WhatsApp: no luck

 

Any recommendations ?

1 ACCEPTED SOLUTION

Accepted Solutions
Apprentice

After reviewing the issue again, I tested it further and have now found the solution to the issue. It's not WhatsApp but Android/OS settings and related to Edge lighting.

 

To Fix and allow WhatsApp bring the incoming call screen up, follow these steps

 

  1. open Settings > Display >  Edge screen > Edge lighting
  2. choose either option A or B below.

 

Option A: Disable Edge lighting

 

Option B:

  • Enable Edge lighting
  • go to Manage notification
  • disable 'Receive notifications' for WhatsApp

 

Have Fun.

23 REPLIES 23
TracyR Moderator
Moderator

Hey @Reinhard!

 

I've tested this as well, it's not a bug with the phone it's a feature that simply isn't avaialble at the moment.

Facebook lights up the screen, but WhatsApp does not. 

 

You may want to contact WhatsApp directly to see if it is limit on the version they have for Android phones. 

 

:womanhappy:

Sherlock 2.jpg
Say "hello!" and
 
Introduce Yourself, or virtually hangout in the Samsung Lounge

First Poster

I am having same peoblem, pls let me know if you find any fix.

 

 

Apprentice

After reviewing the issue again, I tested it further and have now found the solution to the issue. It's not WhatsApp but Android/OS settings and related to Edge lighting.

 

To Fix and allow WhatsApp bring the incoming call screen up, follow these steps

 

  1. open Settings > Display >  Edge screen > Edge lighting
  2. choose either option A or B below.

 

Option A: Disable Edge lighting

 

Option B:

  • Enable Edge lighting
  • go to Manage notification
  • disable 'Receive notifications' for WhatsApp

 

Have Fun.

New Member

When my phone is locked and screen is off and I receive a call on WhatsApp, a notification about the incoming call displays briefly, but the screen remains off. How can I make WhatsApp turn on the screen to show the incoming call screen ?

Phone: Samsung Galaxy S8 - Model SM-G950F
Android: 7.0
Samsung Experience version 8.1
WhatsApp Version 2.17.254

Always On Display is disabled. Having it on makes no difference.
I have tested the behaviour with IMO, Messenger - these apps do turn screen on for incoming call.

Checked on S8 of a colleague who experiences the same behaviour. I believe it's a WhatsApp issue and sent them an Email, but don't expect a response.

New Member
Thank you...that worked for me!!!
First Poster

I've noticed and was bothered by the same thing, but figured out that when a call comes in, hit the power button and you'll get the desired call screen.

New Member

Many thanks,  worked for me too. 

Observer
Thank u. It worked
First Poster

Thank you

Top Liked Authors