Open search

Secondhand Galaxy S4 won't connect to Win 10

First Poster

I have tried 6 different USB cables. 4 are supposed to be sync cables, 2 are MHL cables which charge only. The sync cables make the computer connection sound but don't show up on the computer. I have tried Smart Switch and Kies but phone still won't connect.  They all charge the phone OK. I used to have an S3 that connected to Win 7 OK.


I looked into buying a genuine data cable but see a lot of claims which aren't backed up by feedback. Does anyone know where I can get a genuine cable from?


I looked at Device Manager and saw an unknown device with a yellow triangle and black exclamation mark. I have tried uninstalling and reinstalling.


I have spent many hours on this, just to download 4 pictures. Can someone please suggest what to try next?

Superuser I
Superuser I

Hi @justmegt ...why don't you try to use Direct WiFi to transfer your files ?


Si j'ai pu vous aider un peu , cliquez sur le POUCE, Si j'ai résolu votre problème cliquez sur « Accepter comme solution » pour aider ceux qui se posent la même question. Merci
I f it help you a bit, click on the THUMB, If I solved your problem click on « Accept as a solution to help those who ask the same question. Thank you
First Poster

Tried WiFi. Only Router appears.

Tried WiFi Direct. Nothing Appears


After many hours, tried:

Win 10





I saw 'Unknown USB Device (Device Descriptor Request Failed)'

Driver Error (in grey)


I clicked 'Remove Device' and clicked 'Yes' to the message 'Are you sure that you want to remove this device'


Re-inserted USB cable and suddenly my phone appeared on computer. I downloaded my pictures and tried it again.


Every time, since then. I get the error 'Unknown USB Device (Device Descriptor Request Failed)' and my phone won't connect.




Top Liked Authors