Open search

Samsung galaxy s8+ google play android 8.0

First Poster

Ever since I updated to android 8.0 my Google play store hasn't been working properly anymore.

It takes forever to download any app (+30min) and I can't press update all or it won't do anything! It constantly just shows the downloading text. I don't see anything from how many MB has been downloaded allready or anything.

I tried all the known things allready, clear cache, force stop, remove updates ( what gave me another problem, I can not update Google play neither!) I tried everything I could think of and try. I hope someone can help me, this phone is barely half a year old.

Superuser I
Superuser I

Maybe consider as a last resort back up and Factory Reset. 



Current Phone ~

Samsung Note 10+ 5G _256Gb > Model: SM-N976B._ Samsung One Ui / Pie.

Samsung Gear s3 Frontier Watch
Samsung Galaxy Tab A {2016}SM-T580

First Poster

Done that as well, doesn't work. And it's only this phone, I got an s6 an a5 and a Samsung tab and they work fine 

Top Liked Authors