Support

Open search

Samsung galaxy ace call barring

Highlighted
Apprentice

My phone is not accepting calls, just sending me a text saying I have missed  call and have a message.  The call log gives me the number of the caller.

 

I can make calls. I can make and receive texts.

 

There is no option on the phone to stop call barring.  It should be under settings, call settings, but there is nothing there. Ninhave checked everywhere else for it also.  Therefore I cannot turn it off (jor of course turn it on in the first place!).

 

Excllent signal on thr phone and software up to date.

 

Any help appreciated

7 REPLIES 7
Highlighted
Superuser I
Superuser I

Do you have voicemail activated on your phone @Jan101 ?

 

I ask because normally if a call is going too fast to voicemail then the Network has a process to extend the ringing time. 

 

Also Network Signal Strength can play a part. 

 

If a phone has Call Barring then this is typically found in the phone app and then settings or logs. 

My advice comes from being a UK Samsung Phone User.
Current Phone ~

Samsung Note 10+ 5G _256Gb > Model: SM-N976B._ Samsung One Ui 2.1 / Android 10.

Samsung Gear s3 Frontier Watch.
Samsung Galaxy Buds.
Samsung Galaxy Tab A {2016}SM-T580

Highlighted
Apprentice

Thanks BandofBrothers,

 

The caller gets one ring and then it goes to voicemail telling them that I am already on another call (when I am not).  There is no phone setting requesting this.

 

Three (UK network operator) have looked in to this for me and believe it is call barring which they cannot solve.

 

And yes, call barring should be in one of those setting, but it is nowhere on the phone.

 

Their only possibe solution was for me to put the sim in another phone on Three, which I do not have.

Highlighted
Moderator
Moderator

Hi @Jan101.

 

Is this the GT-S5830? If so, try Settings > Call Settings > Call Forwarding, and check that Always Forward is disabled.

 

If it’s disabled and you’re still experiencing the same issue check to see that the other forwarding options are disabled; and if it's still persisting then try Settings > Applications > Manage Applications > All > Phone > Clear Cache and Clear Data.


 Say "Hello!" to the Community in The Introduce Yourself Thread.


Highlighted
Apprentice

Thanks AntS,

 

All call forwarding settings are disabled, and always have been.

 

Just tried clearing cache and data and the problem still persists.

 

Yes it is the GT-S5830i.

 

Looking a bit like a new phone to me !

Highlighted
Moderator
Moderator

@Jan101: Are you able to try it Safe Mode?


 Say "Hello!" to the Community in The Introduce Yourself Thread.


Highlighted
Apprentice

Hi AntS

 

Followed your instructions for safe mode, does not work on this phone.  

 

Thanks all the same for trying.

Highlighted
Moderator
Moderator

No worries. :robothappy:

 

If you were looking more towards rescuing it though then I'd advise getting it checked out at your nearest Support Centre.


 Say "Hello!" to the Community in The Introduce Yourself Thread.


Top Liked Authors